Assignment 2 working exactly half the time due to create yearly report workflow

There are 2 groups of error I get when running the performer, dispatcher works just great but performer, in one case, successfully ended transaction 1, failed 2, successful 3, failed 4, went all the way up to 18 this way and when it fails it takes a looong loooong time to fail, it waits until the default time threshold is reached and then throws in the error and goes to the next transaction. if I send this very workflow right now i’ll get a 50/100 score since I have 9 successful and 9 application exception in orchestrator queue.


This is from the output panel I don’t know how readable those lines are but it is related to the click save activity in the download monthly report sequence. Sometimes in the middle of those 2 errors I get this one but it is not 100% of the time

Invoke System1CrateYearlyReport workflow: Cannot find the UI element corresponding to this selector: wnd app=‘iexplore.exe’ cls=‘IEFrame’ title=‘ACME System 1 - Reports - Download Monthly Report - *’ />wnd aaname=‘Notification’ cls=‘DirectUIHWND’ />ctrl automationid=‘IENotificationBar’ />ctrl name=‘Save’ role=‘split button’ />

If you notice the opening signs are deleted “<” removed them from the error so that it can type into the thread, they are there normally.

This is the activity I believe I am getting errors from. the top activity named Click Save. The selector has the wildcard implemented, only the title has it, the rest states that its a notification, role is split button etc.

Second error group I encounter is

Again this is also related to the saving monthly report sequence in the create yearly report workflow. As you can see in the second screenshot, one transaction fails, the next one works perfectly. the selectors are fine, I double checked every selector in the workflow even created notification pop-ups to see if there is a problem even though I didn’t think it is. Followed the walkthrough pdf for the second time to see if there is a difference, there is nothing that I can notice. The activity that generates those second set of errors is this On Element Appear. The selector has the wildcard implemented in the dynamic part of the text, it goes as follows; text=‘The Report-* download has completed.’

is there any possible explanation that will produce this or am I just become the special snowflake? I mean the first thing that comes to my mind is the robot does not close all applications properly and the residue affects the next transaction, when I get an error it proceeds with a proper close all application and the next transaction works great but the information type of output clearly states that its closing all applications, if there were a problem with that I figure I’d get an error related to the situation.

You got any solution for it. I’m also stuck in the same problem

I wish. I started all over to have a fresh view on what I am doing but I am still having problems with the robot, If you have any other problems I might be of help, but this one, Decided to pick my battles and accepted that I lost this one :smiley:

Hi @Ruhat_Sengul did you edit the config file to state where the files should be saved in?

Yesterday night I have solved the assignment but it was late and didn’t got the time to explain it in the thread, I’ll do that now and after, I plan to take the certificate exam, Do you have any last minute suggestions before I take the exam? :smiley:

I have solved the problem, It was due to selectors changing on the second transaction, The way I fixed it was with the debug tool and used step into to exactly see at which activity I have to fix.

Since the problem only persisted when the iteration was at 2, I had to let the robot run for 1 full taxID, upload the report, yadi yadi yada and then locate all the broken ones, the title was the problematic part for my selectors and I just unchecked the title selector from the faulty ones in the create yearly report sequence, locating all the bad ones was a long process but in the end it worked like a charm.

2 Likes

Oh that’s great, congratulations @Ruhat_Sengul, Nothing much to say other than ‘go get your certification’ :partying_face::partying_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.