Assignment-2 Submission And Evaluation Problems


#1

Hey Guys,

Greetings!.

Thanks for providing me support and helping me in completing the assignments.

While testing i am facing an issue. Once the yearly report is uploaded. It shows the confirmation ID. In that case, I have been faced with 3 different outputs: “is bad” , “has some values” and “undefined”.

After entering the Confirmation ID output in the comments, my bot sets the status “Completed” and Clicks “Upload Work Item” and popup shows “Work Item Updated Successfully!” and closes the “Update Work Item” window and processes next "Work Item ".

After the overall execution completes, I am going and checking the “Work Items” panel all are in status “Open” and not even a single work item is in status “Completed”. But in Orchestrator it shows all the transaction items are completed.

Pls help me in resolving this issue guys.
@Rammohan91 @prankurjoshi

With Regards,
VP


#2

Reset the test data. Run Dispatcher work flow then run Performer workflow then Submit your assignment. Also please make sure you have trimmed you UploadID


#3

Hi Prankurjoshi,

If UploadID is bad or undefined then whether it is a problem or just value?


#4

UploadID is bad means there is some mismtach between the data which is completed. So you must reset your data everytime you run the project then Run Dispatcher then Performer.

Apart from this please don’t create multiple posts on same topic Assignment 2 should be one topic on which you should ask every query. Use just one it will help us saving time of each and everyone and keep the forum clean and organized


#5

Sorry for the trouble, I was not clear about that how to post. Hereafter I won’t create multiple posts on same topic.

And once I have reseted the data and tested again. I will let u know if there s problem or it s working. Thanks for the support dude.


#6

Great, sure anytime bro. I did the same thing :smiley: when I was doing the assignment


#7

For UploadID I have used the below statement. Pls verify whether it is correct or not:

out_UploadID = UploadConfirmation.Substring("Report was uploaded - confirmation id is ".Length).Trim

(**Note: **UploadConfirmation is the output variable of the GetText activity)


#8

This would work fine


#9

Bro, I have tried to pass default values and check the UploadID for one workitem and once I upload the YearlyReport file, I have got “Confirmation ID undefined”.And I have tried to print the UploadID on the console, I have got the following result. FYR, I have attached the screenshots.

. When I am running the Performer workflow, it shows Transaction Completed and it is updating the workitem. But in the WorkItems panel it is showing Status = “Open” and not as “Completed”.


#10

Hmm have you tried resetting your data first?


#11

Bro, I have kept the Monthly Reports and Yearly report in the same directory so only it causes problem I think :thinking:


#12

No it doesn’t. they should be in the same folder only, program fetches it by full path so no issues there


#13

Ok I have changed back everything to same directory. When I try to upload the YearlyReport file manually at that time also it shows “Confirmation is undefined” msg.


#14

That should only happen because of the mismatch in data. Reset test data and run everything, log message for start and end or workflow it will help us locating exact error and place


#15

Bro I have resetted the data and started the execution again, same problem comes “Confirmation Is undefined”.

All I have done aresame as Walkthrough file but for uploading the YearReport alone instead of giving the YearlyReportPath as input I have done like this “ When I click the upload report button automatically the directory where YearlyReport generated is showing. So I directly use Click Image Activity To click the YearlyReport file and then Click ‘open’”. Whether it causes any problem?


#16

But are you sure it is picking up the right yearly report?


#17

Yes bro it is picking the correct report only but it is showing undefined, by the time while I am testing I have stopped the execution once it opened the dialog and I have manually selected the file and I uploaded it at that time it is showing the correct ID.

. These screenshots are taken while I am doing manually. I cant identify what is the problem :smirk:


#18

Try to add some delay between clicking the upload button and Get Text(Get upload id) activity, this might be occurring because as soon as you hit Upload Report the program is trying to get the Upload ID. You are almost there :smiley:


#19

Thanks bro, It finally worked :smile:. But I am stuck with this I am trying to print the output value of the getText activity but I am getting like this…


#20

Can you show me the selector of Get Text and I think you are using Firefox right?