Assignment 2 Performer system exception illegal characters in path (create Yearly report)

When my Performer bot runs, I’m experiencing several issues. When there isn’t a report to download, I am getting a log message that there are illegal characters in path (see screen shot below). If a report is found, my clicks for save aren’t working. I’ve tried modifying the selectors every possible way I can think of and it still won’t work. Also, the workflow isn’t cycling through the months. I used the for each month so I"m having trouble understanding why it isn’t working. Any help would be much appreciated.

System1_Create Yearly Report.xaml (27.6 KB)

trim the variables or input parameters that you are using in the type into path activity. use trimEnd and trimStart in the variables.

answer

Assignment 2 Performer.zip (59.5 KB)
I updated but it is still giving me this error. Could the issue be where i invoked the workflow in process.xaml?
System exception.Illegal characters in path. at Source: Invoke System1_Create Yearly Report workflow: Assign

can you please log the path on console before Bot writes it.

To do this, I would need to add a “log Message”?

I think there are more illegal characters in your path. You have to trim the all the variables and parameters when u assigning or declaring. If it not works let me know.

You don’t need to add log messages at always, but if u add log messages u can find the error location exactly.

I don’t know what else to trim. When I tried adding trim to +in_Year+, the Tax id wasn’t populated on the vendor report screen.

With the log messages, I’ve been able to narrow it down to the “assign out yearly report path”. I tried adding trim and it still mentions illegal characters.


Put some write lines and print variables one by one then you can find the error, also print in_reportdownloadPath. If there some white spaces it may be illegal caharacter. Please upload ur current workflow file.

Which activity should I use to print in_reportdownloadpath?

System1_Create Yearly Report.xaml (28.9 KB)

try this file.

System1_Create Yearly Report.xaml (28.9 KB)

or paste this path in to the out_yearlyReportpath
path.Combine(Environment.CurrentDirectory, in_ReportsDownloadPath, “Yearly-Report-”+in_Year+"-"+in_TaxID.tostring.TrimStart.TrimEnd+".csv")

Thank you Nalaka…it worked! So I had an extra “-” which was throwing it off? It seems to be running really show when iterating through the months…any ideas?

Yeah, and there were extra " in your path that was the error that i found.For those slow activities,in options, you can put their wait for ready property as “None”.

That worked like a charm :slight_smile: One last thing…I’m to the point where the report has uploaded but I’m having trouble getting the comment section of the work item populated with the UploadID. Should I use in_UploadID in the comment section and in_status to set the item status?



I feel like I’m in the homestretch.

Yes, you can use. In_comment use variable as in_uploadID and in_status select “Completed” using simulate click button.

I keep getting this system exception message
System exception.Object reference not set to an instance of an object. at Source: Invoke System1_Update Work Items workflow: Anonymously Hosted DynamicMethods Assembly

It makes its way back to the work items tab but doesn’t click on the button…then it goes back to the home page
Assignent 2 for update workitem.zip (61.5 KB)

So in this exception comes when u are using the variable before create it.

Are u using back button in the browser ?