Assignment 2 : Object reference not set to instance of object

I am trying to work on assignment 2 and facing error at get transaction data as “Object reference not set to instance of object” and Orchestrator Queue name is given correct at config file


Dispatcher already uploaded to queue and items in New status

Hi @Leela_Javvaji

Can I see how you have mentioned the queue name in get Transaction item activity. May be the way you have specified that is wrong.

As an additional note, to easily locate the error, you can use the debug mode which will show you the exact activity which is throwing the error…

1 Like

Thanks @Lahiru.Fernando

I am able to get where I have missed i.e in_transactionnumber datatype is set to string instead of int32 but same details are not displayed in process transaction

image

Hi

Yes… looks like you are not passing the value to transaction item variable see the screenshot. Its bull in process state. So make sure you assign the int value to out_transactionItem in the GetTranactionData state so that it can be passed to process state. It should work

1 Like

Hi @Lahiru.Fernando

I tried to troubleshoot multiple times but could nt get . WIID is passing to main workflow but the same is not passing process.xaml. Can you please help to check . I am missing arguments passing way concept always :frowning:Assignment2_mAY.zip (1.3 MB)

1 Like

Yeah… I remember you had some problems with that in a different assignment. Anyway… I will take a look into your assignment and let you know what I find :slight_smile:

1 Like

Hi @Lahiru.Fernando

Any luck on the project?

I was trying to execute your project. In mine it just gets hanged at the data scraping stage… I’m trying to figure out why that happens… it just gets there and stops… nothing happens after that. hmm… trying…

Hi @Leela_Javvaji

I ran the program… it takes the data from the GetTransactionData and passes them properly to the Process state. I was able to run it until that point. Did not come across any errors…

Where exactly is your error coming from? Did you try using the debug mode and do a step by step execution to locate the error?

ok…Its running fine till Get transaction data. Issue is at Process transaction - Not fetching WIID to Navigate to WIDetails . Trying to troubleshoot but could nt get

Yes… that is because of the mapping is not done properly in GetTransactionData

Click on Import Arguments to update your argument list. Then add the proper variables. Then it will pass the value to process :slight_smile:

2 Likes

Hi @Lahiru.Fernando

Its added already.Not sure why its missed in your screenshot . I can see WIID passed back to main workflow.


But its not passing the variable to Navigate to WIdetails. Not getting that point from yesterday.Please check and help

Need help on this. Unable to proceed with assignment 2 . I think missed minor point in passing the arguments to Process transaction but not able to get that