Assignment 2 cannot read CSV file

In advanced training assignment 2, there is a task asking to save a monthly report in the temp folder, but the downloaded file name is cut off.

It works up to the point where the program clicks on the save button, and the file is saved in the correct folder. However, the file name is cut off.

The path is correct, including the correct folder and file names like:
C:\Users\XXXXXXXX\Desktop\Assignment_2_Performer\Data\Temp\Report-AB123456-2018-January.csv

but after hitting the Save button, when I check Temp folder, the saved file is named

C:\Users\XXXXXXXX\Desktop\Assignment_2_Performer\Data\Temp\Report-AB123456-2

As you can see, the file name is cut off halfway. Because of this, the program cannot find this file in the next task. Why does this happen? How can I fix this?

1 Like

How do you entering the file name in the save as window?

2 Likes

I had the same issue where at times the robot was simply not typing part of a filename when I was going to save a file. To fix it we added a ~500ms delay to the DelayAfter and DelayBefore properties of the type activity.

If that doesn’t work try making the DelayBetweenKeys slightly longer. The issue seemed to be happening if the bot was typing too fast.

2 Likes

Buddy i hope you have enabled the simulate type property in type into activity which is the fastest of the input methods we have like default, sendwindowmessage and simulate type
Because of that it will type very fast than the default method,
So our prime step is to slow down a bit first and then we can include delaybetween keys with some time lapse
so disable simulate type and enable the sendwindowmessage and include some time in delaybetweenkeys, that would work for sure
Cheers @tomato25

1 Like

This is what it looks like.

2 Likes

Did that work buddy @tomato25

1 Like

Thanks for the answers all, but when I run the program in debug mode step by step. the file path is fully entered in the Save As window, but when it hits the save button, it only saves the incompletely-named file.

I also added 500ms for Before, After and between delays, but still it doesn’t work. It is only saved incompletely-named files.

Here is the property I have for the type into activity. Can anyone tell me what I did wrong?

Also, regarding simulate type, the instruction is explicitly asking us to check Simulate Type, but should I still uncheck it ?_?

2 Likes

Fine buddy @tomato25

–increase the Delaybetweenkeys as 1000
–and let the simulatetype be enabled
–alongside enable these properties as well
ClickbeforeTyping
EmptyField
–then mention the delayafter property as 1000
and the delaybefore property as 1000

Kindly try this and let know if you face any issue
you were almost done
this can be resolved
@tomato25

1 Like

To clarify, you saw it type the full “C:\Users\XXXXXXXX\Desktop\Assignment_2_Performer\Data\Temp\Report-AB123456-2018-January.csv” when it was in debug mode?

Sounds like there might be a setting outside of UiPath that is affecting the file.

  • Can you manually save a file with that name to the destination?
  • If you go to the site and download the file and give the same filepath as the bot does it save correctly?
2 Likes

Yes! In debug mode, I use “Step Into” so I can check the flow one activity at a time slowly, and I do see it type the whole correct path in the SAVE AS window. However, once it hits the SAVE button, the saved file is named incorrectly!

But! instead of the robot typing the mentioned path one key at a time, it looks like it types the whole path at once. Do you think that might have something to do with this issue?

I just unchecked the Simulate Type and it worked, but as explicitly specified in the instruction, I would like to keep Simulate Type checked because there must be a way to make it still work like that.

2 Likes

Thats what buddy simulate click will type much faster as it is the fastest of input method as mentioned earlier…so disabling them would work for sure
Though it is mentioned in the instructions, sometimes we need to get out of box buddy
and we are not trying to heal this issue for now, as disabling simulate type and enabling sendwindowmessage is not going to affect in future, we are just trying to slow down the typing speed that too in small fraction of milliseconds
Cheers @tomato25 . so i would suggest to go with sendwindowmessage rather with simulate type here

4 Likes

Thank you very much for your help. It works wonders now!

1 Like

Cheer buddy @tomato25
Keep going

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.