Assignment 1: Issues related to Hashcode workflow

Hello Guys

I have submitted my first assignment and there are couple of concerns I need to address here

  • There were 20 items and 17 items were completed
  • After the 2nd,13th and 18th items, I got the following error and the respective items were not processed
    A.Go Back: Error HRESULT E_FAIL has been returned from a call to a COM component
    B.Invoke GetHashCode workflow: Error HRESULT E_FAIL has been returned from a call
    to a COM component
    -Assignment results shows correct items as “0” when 17 items were processed with no issues

My questions are

  • Why this error happened only for 3 items not for others
  • When 17 items were processed & completed, Why the result shows as correct items as “0”

Sorry to make it long.I fixed a lot of bugs but this one on hashcode stuff keeps recurring

Your help would be highly appreciated

1 Like

For error - try this

And for the second error, follow these -

  1. Reset Test Data
  2. Clear your queue items or create a new one with same name deleting the previous
  3. Run the workflow
  4. Verify that Work items are set to completed with correct hash code (trim client id, name and country {delete the surrounding spaces and also trim the hash code}) in the comments section
  5. Upload your ZIP
  6. After upload, do not reset test data until the evaluation is done.

Karthik Byggari


No worries
Let’s go one by one

So for this
This must be due to that the hash code Might not be entered and updated with the comment with that hash code (concatenated with - inbetween)
So kindly check once with that
to make sure that part is done correctly use a writeline activity or log message activity with that hascode as string, before updating the comment with that concatenated hash code
This will help us to debug whether we have mentioned it correctly or not
Then we will surely come to know the issue we’re we are lagging
—Make sure that the data in your portal is RESET AND IN YOUR QUEUES as well

You were almost done and this will work for sure

Then for this

Still we are not sure whether it’s 100 % correct or not buddy
The reason is the result that we get after validation of our assignment shows as 0%
So as mentioned above we need to cross check with the value once
—Use write line or log message and check with the value
— kindly run in debug mode with highlight option enabled in execute tab under options drop down so that we could get to know how the flow is moving

Fine then this error issue usually occurs when the bot is not able to converse like communicate with the browser or any other application
As we have only browser here make sure that extension is installed if we are using chrome
Or to be better kindly use IE instead of chrome
—if we have to use only chrome then uninstall it and reinstall again and try once pls

Hope this would help you
Kindly try this and let know for any queries or clarification
Cheers @gorahul

1 Like

So any other queries buddy
Cheers @gorahul

I will work on this and then well get back to you
You are awesome mate

1 Like

No worries
Cheers @gorahul

1 Like

Hello karthik
Thanks for your help mate
I did check the link you shared for “Error HAShREULT” stuff. The answers points out 2 solutions

  1. Use IE. I have never used chrome and always used IE
  2. To Install .Net. Is it mandatory to install .Net to clear out this error

Again this error didn’t happen for all the items ,only few which leaves me confused

It all worked good for all the 17 items but 2 got this HASH Error
Can you think of what is going wrong here
Thanks for your help in advance

Hello Robo Master aka Palaniappan

All went well untill this HASH error came and ruined everything
Error:Go Back: Error HRESULT E_FAIL has been returned from a call to a COM component.

It happened only for 2 items and for those transactions, the respective browser windows (System 1 (Work Items) and SHA1) did not close as well. Robot did came back to the Work Item windows to update comments and status

So I got all the 18 items completed, 2 failed due to this hash error

Can you think of what is going wrong here

Hello Mate
It worked and I cleared the exam too; Had to review a bit on debug mode to troubleshoot the explorer but finally it worked