Assign or type into activity causing problems when trying to set ReportFilePath (Level 3 - Assignment 2)

I have found a topic about the same problem but it dies at some point. The robot enters the Vendor TaxID correctly, selects the year and month, clicks download report button, continues with save as and in there, I am using an assign activity to create the name and the location of the .xlsx file I want it to go, I am using the function provided from the documentation since it has a screenshot of what to type in the assign activity. I think I can’t go wrong with that :smiley:

Path.Combine(Environment.CurrentDirectory, ReportsDownloadPath, “Report-” + TaxID + “-” + Year + “-” + month.ToString + “.csv”)

The line I am mentioning is this one. It gets the current directory, moves to download path, no problem there, types the Report- string and then only types the initial letter of the taxID, doesnt continue to type, after a while it times out and then tries to continue with the workflow. Since the name is not entered correctly Merge data table can not locate the monthly report to merge with the yearly report.

This is basically what I get, it stops at Report-R. I run the file instead of the project so it is safe to think this is the troubled sequence


Before this Type Into activity, print the TaxID and year and then check whether it’s values are coming to this flow or not.

Yes I logged the message with TaxID + Year and the result is RO8742312018 so up until type into there is nothing wrong

Can you go for “save” instead of “save as” …

…then try to change the name of the file name…

1 Like

why do you have a " in front of your filepath in ur first screenshot? maybe thats the problem, you might want to check ur config or wherever you have saved your file path, my guess is that you keyed in an extra character somewhere

1 Like

That is a great notice my anonymous mythical hero, but I tried another approach. I put an attach window around the screenshot I have on the bottom and instead of giving all the input in one statement I divided them into two. My curiosity still exists over this situation, why the type into was unable to enter the given value to the bar provided while being able to print it correctly before and after the type into? The initial Type into activity has a PathForSavingDownloadedFile I never liked doing this but it has a hard coded default value in the variables panel, the default value is;


This takes me to the location I want to download and fetch the csv file when the time comes. The second type into activity only has the value of the File that is going to be downloaded and I’ll create a variable for it and assign the name convention before the type into for ease of reading. The file is being saved in the right directory under the name of “Report-RO874231-2018-January” Is it an optimal way to do it, I don’t know. But does the end result is usable? yup yup :smiley:

Here is the workflow that did the trick

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.