'AsEnunerable' is not a member of 'System.Data.DataTable'

I get this error ‘AsEnunerable’ is not a member of ‘System.Data.DataTable’ when it actually is :slight_smile:

I tried this solution adding it via notepad, but it was already added. Any other solution to this?

@jntrk
you can try a restart of uipath
as we execute this very often we do have the trust that it is working

feel free to share with us a screenshot / reference from your XAMl if after UiPath restart it is still not validating.

In a case of a statement is corresct but not accepted we do following:
ctrl + A,ctrl + X, Enter within the assign field - delete it and reset the field
ctrl + V, Enter reset the code

sometimes caches are hanging and the statement corrections are not recognized

@jntrk

It’s a problem when we use old version of studio, but it was fixed in later versions

If you are using old version that was the solution and that works too, please double check that you place the assembly text in the correct place

Thanks

Did you copy and paste the error message when creating the post or did you type it manually? If you pasted it, please check the spelling. There should be a m in Enumerable.

lol I copied and pasted it, how did it copy it wrong :slight_smile:

Can you send all the operation value you are using with enumerable?

Whole assigned value?

It will help to understand if there is anything wrong with syntax…