Arguments being imported not same as in WF

Hi

I have following arguments being passed when I say IMPORT and Save:

But the Arguments look like this when I open the WF. Why are they blank:

@ColinCrabtree
Try printing your arguments in GetTransactionData workflow in message box, you will get the desired values.
The highlighted field is to pass default values, the imported values will not be visible here.

@ColinCrabtree

It’s correct only and inside the workflow it won’t have any values under Default Value field and here you specified directions as In. I e. It’s accepting input from other workflow and we have to pass it by going to Edit arguments option of Invoke WorkFlow Activity and same already you done.

Are you getting any error here ?

Hi @lakshman

Thanks for the assistance. I get the following error:

Arguments below:

1 Like

Hello @ColinCrabtree
for second error
Change datatype of out_transactionItem Datarow from DataRow

Thanks

2 Likes

for first error please share screenshot of GetTranscationItem workflow

Thanks

1 Like

HI @sandeep13

I changed it like this:

But then get validation error on following screenshot:

Cannot assign from type ‘System.Data.DataRow[]’ to type ‘System.Data.DataRow’ in Assign activity 'End Process’

@ColinCrabtree
Just re-write the same text again in Assign activity Nothing

1 Like

Hi,
I have the same issue in the 2019.6.0.

Regards
Balamurugan.S

Hi @sandeep13

I tried retyping it. I also tried retyping TransactionItem but the warning did not go away.
I solved it by re-adding the activity and then deleting the one with the error. This does not make sense so i am assuming its a bug in UiPath itself:

image

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.