Application crashes when UiPath robot interacts with it

I have a Visual Fox Pro application that i could automate in the past but when i tried again after the new 2021.4.4 update i can open the application and send a click to it and then it will become unresponsive. The application is SagaC, it is free and can be downloaded from here: https://www.sagasoft.ro/
i tried using simulate and send window messages and even sending hotkeys(Or keyboard shortcuts) but all seem to just crash the application.
When using it manually i have no issues whatsoever.
What should i do since i updated the project and if i downgrade uiautomation activities even the invoke workflow activity breaks

Hello @Bogdan_Ielcean!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @Bogdan_Ielcean

Could you please update us if the application works with the latest improvements and the 21.10 version? (both Studio and activity packages0