Append Range issue

im facing a problem on my workflow. actyually i’ve been trying to append an excel dataTable to another one knowing that they have the same columns but when i execute it
The output data contains empty rows then added data after it (the ones i wanted to append)
i dont know why it left thoes empty rows left

@kawtar.ettayarssouti

May be some blank values are present just select all rows cand right click and delete and then try

Or you can as well use find last row and select non empty and get last row with empty values and fill from there instead of append

Cheers

im new to UiPath
can you explain more how can i used this method please

Hi @kawtar.ettayarssouti ,

Could you maybe check the Datatable itself that you are trying to Merge with other datatable ?

Or Perhaps use Write Range activity and write the Datatables to two different Excel files, you should be able to understand if the datatable itself has the empty values.

We can also check this by Debugging but for better visibility you could opt the above method.

The 1st Data table contains only headers so the append data should start being added from row 2
and the the table i want to append contains only few line with no space or empty rows

i tried to use write range with " Append" anabled and gave me the same resutls
the workflow worked well only the first time i runned it then keeps giving me this problem after running it again to make sure it works well

@kawtar.ettayarssouti ,

You have mentioned it worked once, that does points to something that is to be reset in the workflow.

Do a Check again, with the initial input data and check if it works as expected.

For faster and better suggestions provide us with the Steps or Workflow Design that you have used, so we can analyse it from our end.

Hi @kawtar.ettayarssouti

Instead of Append range, you can use Merge data table activity.

Source will be your 1st DT
destination will be your 2nd DT

Example:
DT1
image
DT2
image

MergeDataTable
image

Output:
image

Thanks!

i will this suggestion