Append data table is adding blank rows between the prior data set and the new data set

Is anyone else having issue? Tried filter data table but the blank rows are not recognized as blank rows and are left. The only way I can get them to not appear is to use sort datatable

is datatable filtering on blanks done against 1 or more particular columns
should datatable row get filtered out in case of all columns are blank

let us know what you do need.

When we used Datatable filtering we chose only one column. Scanned through the blank lines that were created and no forumulas or data is in any of the cells. We were able to remove the blank lines using a sort function. We did try an append on a different excel sheet and it does the same thing with a totally different file. It seems to be some type of but in the recent package updates?

For filtering the blanks give a try on

assign activity
left side: dtDataFiltered | DataType: DataTable
right side:

(From d in dtData.AsEnumerable
Where Not(isNothing(d(YourColNameOrIndex)) OrElse String.isNullOrEmpty(d(YourColNameOrIndex).toString.Trim))
Select d).CopyToDataTable

I will try this

We tried this but get an error that there is an expectation of another ). Inserted on after the first "Not(isNothing(d… And tried other combinations even with CopytoDataTable() but still get the same error.

@Chris_Bolin - Have you used the little copy icon on the top right corner??

Because I just copied the code and just changed the dt name…and it is perfect…


1 Like

hmmmm…tried again and now get an error that asEnumerable is not a member of systemdata datatable. But, that error did not appear before…

yes I did use the copy icon