App load time impacting copy operation

excel
uiautomation
studio

#1

Hello,

I am trying to copy records from Citrix application to a Local excel file.

However as it’s a legacy app, it displays all the records when I scroll down.

Ex: let’s say app has 1000 records.

Initial display - 100 records
1st Pg down - 100 records ( 100+100 = 200 records are displayed)
2nd Pg down - 100 records (100+100+100 = 300 records are displayed)
and continues.
No limit on the data the app has. It keeps getting added everyday. I feel setting a delay may not be a best option as I do not know how many records will be appended everyday.

Though I tried CTRL+A to select all records, it only copied initial 100 records and rest of the records are blank as it’s not visible but row is being generated for invisible records

How do I copy all records from the app to a excel file.Can you please help me with this?


Citrix automation & local windows - working with two windows at a time
#2

HI @Selvasathappan,

You can use following steps, I am sure it will help you.

  • Open Citrix Application.
  • Copy First Page using CTRL+A (As you are saying it will give you records with all Blank Lines).
  • Store Row Count in one Variable and Divide it by 100, It will give you page count.
  • Now you can use While loop on Page Count and in every iterate
    Page dn and CTRL+A. After that Append in a variable or Excel File. You will get All the Records.

Thanks


#3

You are fantastic. I didn’t think of this. It worked. But just wondering how can we do it if there is no row count. I mean invisible records doesn’t leave any trace of empty rows. Is there any command which will help me find whether a specific row and column value is numeric or not in “If” condition

Actually I would like to stop for loop when it reaches the row which has Numeric value in its 1st column.

Is there only dt1.enumerable type of function. Don’t we have anything simple to use/easy to understand like Python? Apologies am new, and no experience with Uipath and Programming as such

Thank you.


#4

Is there a way to export all the records as excel or csv? That might make our work simpler.


#5

Good suggestion. Though there is an option to export, due to software application issue , it doesn’t work


#6

image


#7

@kaderms @Santan_Barnwal - Guys, Am trying to check whether datatable rows count is 0. As a part of my lengthy script, an excel sheet was read using Excel application scope and stored in datatable variable. Though the excel sheet is empty as expected, when I validate that using the condition (dt3.rows.count =0), it returns false. When I try to print dt3.rows.count it displays a blank message box output window. Can you shed some light on what is happening here?


#8

This is easy to use for beginners like me. Thanks Kaderms