トリガー作成のAPIがエラーになる

こんにちは。いつも勉強させて頂いております。

どうにも手詰まりになってしまいまして、投稿させて頂きます。

トリガーを作成するAPIを実行したいのですが、アクセストークンの取得までは問題なくできるものの
いざトリガーを作成する段で、以下のような内容でPOSTを投げたところ
「404:ジョブの関連プロセスが見つかりませんでした。」というエラーが返ってきてしまいます。
リクエストのパラメータがおかしいのかなとは思ったのですが、適切な設定がわからず・・。

Orchestratorのバージョンは2020.10.11、フォルダ構成はクラシックです。

https://(サーバー名)/odata/ProcessSchedules

{
      "Enabled": False,
      "Name": "hogehoge",
      "ReleaseName": "パッケージ名_ロボットグループ名",
      "StartProcessCron": "0 0 12 1 Mar ? 2022",
      "StartStrategy": 1,
      "TimeZoneId": "GMT Standard Time",
      "TimeZoneIana": "Asia/Tokyo",
}

「Name」を既に存在するトリガーの名前に変更すると
「409:名前 (トリガー名) は既に使用されています」と返ってくるので、
アクセスしている先が間違っている事はなさそうなのですが・・。

調査のとっかかりになるところまでだけでも、お知恵をお借りできればと思います。
よろしくお願いいたします。

@rfu

Try Below steps

  1. HTTP Request Activity → Authentication

  2. HTTP Request Activity → “https://cloud.uipath.com”+"/"+“Account Logical
    Name”+"/"+ “Tenant name”+"/"+“odata/ProcessSchedules(43725)”

                                      -> Process Id/Id : 43725 
                                      -> Body --> 
    

{
“Name”: “ABC_Trigger”,
“ReleaseId”: 158313,
“ReleaseName”: “Process Name”,
“StartProcessCron”: “0 0 0 ? * *”,
“StartProcessCronDetails”: "{“type”:5,“minutely”:{},“hourly”:{},“daily”:
{},“weekly”:{“weekdays”:},“monthly”:
{“weekdays\
},“advancedCronExpression”:“0 0 0 ? * *”}”,
“TimeZoneId”: “AUS Eastern Standard Time”,
“Id”: 43725,
“MachineRobots”:[
{

  "MachineName": "XYZ",
  "RobotId": 129741
  
}

]
}

1 Like

こちら最終的に解決までこぎつけられましたので、後続の方への参考に記しておきます。

https://(サーバー名)/odata/ProcessSchedules

{
      "Enabled": False,
      "Name": "hogehoge",
      "ReleaseId": "プロセスのID",
      "StartProcessCron": "0 0 12 1 Mar ? 2022",
      "StartProcessCronDetail": "{"type":"5", "advancedCronExpression":"0 0 12 1 Mar ? 2022"}"
      "StartStrategy": 1,
      "TimeZoneId": "Tokyo Standard Time",
}

ポイントとしてはReleaseIdとStartProcessCronDetailが必須だったというところのようです。
ReleaseNameでの対象プロセス指定はできないようですね。・・何のためにある項目なんだろう?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.