API requests with space symbol

Hello.

Got this instruction for making some API requests (Building API Requests).
This works great with one parameter requests, and requests without “space” symbol, like this:
‘***/odata/RobotsLogs?$top=20’.

But there is no result when i try to use requests with “space” symbol, like this:
‘***/odata/RobotsLogs?$top=2&$orderby=CreationTime asc’. I tried to change it with +, and %20 - nothing happens. With wich symbol or combination of them i must replace it? Or may be there is another problem?

Thank you!

I haven’t tried this with UiPath but have used %5E as way to include other parameters in a api call

or try to add &order_by=asc or sort_by=asc(CreationTime)

https://docs.uipath.com/orchestrator/reference/about-odata-and-references

Swagger info

Not working.

same result

I found the problem. I tried to sort (order) by a parameter CreationTime. But there is no parameter with this name in result row, that i can get via this API call. The correct request with php+curl is here:


Also do not forget to use “+” instead of whitespaces.

If you need to orderby with any parameter - first check what parameter you can use, by analyzing json. Here is example (red arrows):

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.