API Orchestrator

Hi guys,

When i try to run the robot using Orchestrator API “https://staging.uipath.com/odata/Jobs/UiPath.Server.Configuration.OData.StartJobs” am getting error message.

{
“message”: “An error has occurred.”,
“errorCode”: 0,
“resourceIds”: null
}

Why do you use “staging”? https://platform.uipath.com is our Orchestrator CE, please try with that one.

1 Like

Yeah tried that but am getting this error when i try to use authenticate API.

So, i were used Platform API

Staging no longer exists, it’s removed, so you cannot authenticate. That’s why I suggested to use platform. That one is always up and running with the latest stable version.

@ovi Thanks for your quick response.
Okay but when i try to run my robot using this API “https://platform.uipath.com/odata/Jobs/UiPath.Server.Configuration.OData.StartJobs” after all the authentication am not getting any response intsead of am getting only “400 Bad request”

Please advice on this

Arun, let me try this myself on platform and get back to you. In the meantime you can check the parameters (in case you haven’t) here: https://platform.uipath.com/swagger/ui/index#!/Jobs/Jobs_StartJobs

@ovi Thanks for your time

Sure Ovi will do that and will be waiting for your reply.

1 Like

Hi Arun,

I tried on swagger and platform.uipath.com with the following parameters and it works:

{“startInfo”:{“ReleaseKey”:"bc2ca0bd-9383-48d7-85f3-*****",“RobotIds”:[11],“NoOfRobots”:0,“Strategy”:“Specific”}}

1 Like

@ovi Thanks for your help

It’s work perfectly now

2 Likes

That’s great, Arun! :sunny:

@ovi

Hi ovi,

I am facing a difficulty to convert a local image into Byte array.Please help on this.