如何利用API 去获取 Oc 上的机器人状态

我在postman上面输入了在官方文档提供的 检索机器人状态 的API,但是返回结果没有状态信息,请问我是哪里出了问题?
这个是官方介绍的文档中的API:
{OrchestratorURL}/odata/Sessions?$top=10&$filter=Robot/Id eq 749&$select=State
官方文档地址:
https://docs.uipath.com/zh-CN/orchestrator/automation-cloud/latest/api-guide/robots-requests#retrieving-robot-statuses
这是我用postman查询的结果


Token 是已经添加的,文件夹ID也有在Headers中

@davidsun

Looks like the filter you are using is filtering all the values …try removing the filter and check if you are getting data and then add the filters

Cheers

@Anil_G
Thank you for your reply
I tried removing the filter,but the result is also no information
This is the result of my changes:


I want to know how to fill in the parameters

Kind regards

@davidsun

Can you please remove all the filters first…you still have a robot filter and that looks wrong as well…just run it with no filters and all

And can you please explain what you are trying to get as robots are deprecated now…we have only users…want to understand what you wnat and can suggest accordingly

Cheers

@Anil_G
This is the result of removing the filter:

I want to use API to know the status of robots in Oc

Kind regards

@davidsun

Please try this

cheers

@Anil_G

Thank you for your suggestion
I have used this API,but there is no robot status in the returned information
just like runnning/stopped/pending

Kind regards

@davidsun

Got you…please try these…these will show if machine are available or not and users are available or not

as there are no robots separately in new model you have to go with users and machines only

Hope this helps

cheers

@Anil_G

Thnak you!!!
It’s very helpful for me
By the way,where to view your screenshot of the document

Kind regards

@davidsun

It is the swagger file

to get it <OrchestratorURL>/Swagger/index.html

Hope it helps

cheers