Anchor base with get text giving empty results while pdf extraction

while extracting specific text from pdf using anchor base and get text (after Find Element activity)its giving empty message box instead of values

for example am extracting invoice bill with Anchorbase activity ,after find element i have taken gettext activity and taken message box for the sake of messages(created variables)
while running the program i am getting empty values instead of value.some one help me on this

Please check you are trying to grab data from an image inside the PDF… if possible, please post your WF some one from forum will help you.

this is my work flow

Try to change InvoiceDate and CustomerNumber as GenericValues and see… also keep some delay between both activities to read and produce output.

i have made changes according to your suggestions even though i am unable to get the value

There is some issue with your get text selector which is not producing output values.
try to grab different data on different page in the same PDF… if it is working fine then observe selector values and adjust accordingly.

I have the same issue, and still couldn’t find the solution for it yet. Have you solved this problem? Thank you.

I have the same issue…

I think you are using anchor in pdf , for for PDF we should be using Find Image instead of Find element for anchor , please try that should be working fine


I am having a similar problem where I have used find image instead of find element but I still get an empty result whilst trying to extract from a PDF.

I’ve attached for project so far.

Many thanks in advance,

JeffGetTextAnchorBase.xaml (30.0 KB)

I have same problem. How did you solve this?


I have same issue.When i use get text and indicate on screen it indicates whole the page not a specific ui element.Also change the pdf setting-Accessibility.but didn’t work.