"An Error has occurred message" trying to provision a new user in Orchestrator

orchestrator

#1

Hello - I am getting a message saying “an Error has occurred” when clicking on the Provision button for a new user as an administrator with full access rights to every available role option . I have verified that all information entered is correct. How do I determine why I am getting this error.
Thanks Joe


#2

Hi @bonjoe_191
Have you given the machine key while provisioning the robot because it provides an interface between the robot and orchestrator

Thanks
Ashwin.S


#3

Hello Ashwin

Thanks for your response.

I am not trying to provision a robot but trying to add a user to Orchestrator.

Thanks

**Joseph Boninti **VP, IT Shared Services and Autosys Support NA

Natwest Markets Technology

Americas HQ, 600 Washington Blvd, Stamford CT, 06901, USA

Office: +1 203 897 1454 | Mobile: +1 917 612 9071


#4

Hi @bonjoe_191
Give the username and password for the bot

Thanks
Ashwin.s


#5

Ashwin

I was just giving you the screen where I was getting the error. I completed the page completely but am getting the error.

Thanks

**Joseph Boninti **VP, IT Shared Services and Autosys Support NA

Natwest Markets Technology

Americas HQ, 600 Washington Blvd, Stamford CT, 06901, USA

Office: +1 203 897 1454 | Mobile: +1 917 612 9071


#6

Hello Ashwin

Any further thoughts on this issue? I am still getting this error.

Thanks

Joe


#7

Hi @bonjoe_191
Try to use the below link
Usual Orchestrator errors (FAQ) - Troubleshooting

Thanks
Ashwin.S


#8

Hello Ashwin

Apologies if I am not being clear, but the problem I am having has nothing to do with a ROBOT id.

In Orchestrator, I am trying to add a new User.

Then when I try to provision the user, I get this error with no additional information.


#9

Hi @bonjoe_191
Ensure while creating an user you need to choose administrator or robot for that user

Thanks
Ashwin S


#10

The screenshot did show the role, but I get the same error when I enter any/all roles available.


#11

Do you have the admin access?


#12

Yes, I am logged in as admin.

I have created several users in the past.


#13

Hi @bonjoe_191,

Please check the Event viewer on Orchestrator server for any errors. This kind of errors are returned by the sever so a more detailed error should be displayed in EV.

Thanks,
Andrei


#14

Hello Andrei

I have looked at the 3 event logs on the Orchestrator server.

This error appears in the application logs.

I can be certain that I am logged onto Orchestrator with an Admin account. I can also be certain that I am entering a password that conforms to the setup. I’ve
tried several times.

As mentioned previously, I have been able to add new users in the past. I am not sure to what user / password the error below the error is referring.

The full description is attached.

The description for Event ID 0 from source Orchestrator cannot be found. Either the component that raises this event is not installed on your local computer or
the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

The user name or password is incorrect.

System.DirectoryServices.DirectoryServicesCOMException (0x8007052E): The user name or password is incorrect.

at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)

at System.DirectoryServices.DirectoryEntry.Bind()

at System.DirectoryServices.DirectoryEntry.get_AdsObject()

at System.DirectoryServices.PropertyValueCollection.PopulateList()

at System.DirectoryServices.PropertyValueCollection…ctor(DirectoryEntry entry, String propertyName)

at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)

at System.DirectoryServices.AccountManagement.PrincipalContext.DoLDAPDirectoryInitNoContainer()

at System.DirectoryServices.AccountManagement.PrincipalContext.DoDomainInit()

at System.DirectoryServices.AccountManagement.PrincipalContext.Initialize()

at System.DirectoryServices.AccountManagement.PrincipalContext.get_QueryCtx()

at System.DirectoryServices.AccountManagement.Principal.FindByIdentityWithTypeHelper(PrincipalContext context, Type principalType, Nullable`1 identityType,
String identityValue, DateTime refDate)

at System.DirectoryServices.AccountManagement.Principal.FindByIdentityWithType(PrincipalContext context, Type principalType, String identityValue)

at System.DirectoryServices.AccountManagement.UserPrincipal.FindByIdentity(PrincipalContext context, String identityValue)

at UiPath.Application.Users.UserService.d__16.MoveNext()

Thanks

Joe

(Attachment error.txt is missing)


#15

Ok, I see in the ss from above that you also have the domain filled in.
If you want to provision a domain user, then you don’t have to specify the password or the email since they will be retrieved from the AD, just a username that belongs to that AD

If you want to provision a normal user in Orchestrator, please delete the domain.

If this doesn’t do the trick, please login a support ticket.
Also, please tell me the Orchestrator version, I want to investigate this further.

Thanks,
Andrei


#16

Thank you Andrei

I was now able to create the user.


closed #17

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.