Amazon Web Services (AWS) Activities are now in Public Preview

@tagaramsrinivaskarthick: token is not required for the AWS Scope activity. For the Region you shall set a value like “us-west-2” for example. See here a list of AWS available regions Regions and Zones - Amazon Elastic Compute Cloud



I am having some trouble using the activity “For Each Object in Bucket”, I can’t access to the objects in bucket, I get this error:
“For Each Object in Bucket: Failed to get s3 object: Access Denied
Error: Access Denied”
While using the same credentials and executing code in python, I can have access to the objects without any problem.
Does Uipath need any special permission anywhere??

Tell me if you need to see a screenshot or the code itself, thank you in advance!

1 Like

Hi @Gmar
You should have “ListBucket” &/ “ListBucketVersions” permissions.


Thank you very much!!

1 Like

Hi @ovidiuponoran ,
I am facing the same issue as @mrkrunaldoshi, getting the error below when I use the GetObject activity :
Failed to get s3 object: Access Denied
Error: Access Denied —> RemoteException wrapping Amazon.S3.AmazonS3Exception: Access Denied —> RemoteException wrapping Amazon.Runtime.Internal.HttpErrorResponseException: The remote server returned an error: (403) Forbidden. —> RemoteException wrapping System.Net.WebException: The remote server returned an error: (403) Forbidden.

We are able to access the bucket and display its creation date for example, but we can’t get an object.
We’ve tried it giving full access on buckets to the robots. The difference with @mrkrunaldoshi is that we use AccessKeys credentials to connect to AWS instead of IAM Role.
Do you have any idea of what could block the access to objects inside the bucket?

Thanks in advance,

1 Like

Hi @adrien.jacquart

Did you set “ListBucket” & “ListBucketVersions” permissions for the Bucket?

1 Like

Yes we tried giving full access to our profile.
We ran a rest api call through POSTMAN :
It returns the first 1000 objects without problems.
I only get “Access Denied” when working with the library in my Studio

1 Like

@Manas_Pandey can you please help @adrien.jacquart to find out what can be the issue in his environment that prevents him from reading S3 objects?

1 Like

Hello @adrien.jacquart,

Thanks for reaching out to us. If I understand correctly, you are facing issue while calling the GetObject activity. And you are using AccessKey/SecretKey combination to authenticate against AWS.

Could you please let us know what permissions/policies the user corresponding to AccessKey has? To illustrate further, GetObject makes following calls to fetch various metadata of an object:

  1. GetObjectMetadataAsync

  2. GetBucketLocationAsync

  3. GetObjectTaggingAsync

  4. ListVersionsAsync

So the user should have either Full Access on S3 operations or combination of individual permissions for above operations.




Hello Manas,
Thank you for your help and quick answers.
We’ve made some more tests with the library, starting with full rights admin and then taking rights out one by one until a suitable level of rights is reached.
We were able to access the objects with following rights:
Anyway, that is awesome that you provide us with this kind of library. It will be a huge help for us, thanks a lot!


1 Like

@adrien.jacquart, happy to hear that it worked.

1 Like

Hey, can we get the OS Type from the Get Instance List or Get Instance by ID activities? Thanks!

Hi @lbell92. Currently, the AWSEC2Instance object returned by the activities you mentioned does not offer info about the OS. I will add your request to the backlog for the next version of the package.

Is there any other info about an EC2 Instance that you find it useful to be offered via AWSEC2Instance object?

Hi Can you please tell how you resolved the issue.I am also having the same access denied issue

please see my replies from this post AWS Access Denied when download file from bucket - #2 by andreioros

1 Like

What should be the permissions granted for us to successfully upload a single file to a subfolder? We are able to a reference to AWSS3Bucket object using the Get Bucket activity but we get an “Access Denied” error when using the Upload Object from File activity. What should be the granted permissions?


Hi Edward,

Here are the permissions you will need




Is it possible to build a Rhel instance using the AWS activities?

Use Create Instance activity and set the ImageId to the Amazon Machine Image (AMI) that you want to use.

1 Like

Hi fellows, Can you help me with my problem here? I tried initializing an Amazon Web Services Scope activity but this error appeared during debug.
Not sure what I am missing.