"alt" + "c" with Polish language

Hello,

In Poland “alt” + “c” is a “ć” letter. But… in UiPath Studio it is “Citrix Recording”. It’s very annoying because “ć” is often used in Polish.

How to turn off this keyboard shortcut?

Regards
Joanna

image
Citrix shortcut is Ctrl+Alt+C

But when I type on POLISH keyboard “ć” (“alt” + “c”, without “ctrl”) then “Citrix Recording” runs… And I haven’t this polish letter…

How to turn off this?

BTW: my colleagues have the same problem…

Regards
Joanna

Please change your keyboard type.
http://www.wikihow.com/Change-Your-Keyboard-from-American-to-English

It is not a solution. In Poland everyone uses “Polish (programmers)” keyboard. Because of:

  • “Z” and “Y” position on keyboard
  • polish signs like: ą, ć, ę, ł, ń, ó, ś, ź, ż

How can I wrote in easy way string “jakże ciężko chrząszczom świecić” if I change the keyboard type? :wink:

Regards
Joanna

Confirmed.
AltGr key (which is in place of right alt on standard keyboards in Poland and quite a lot other countries) is interpreted by Windows as LeftControl+RightAlt.
Unfortunately I don’t seem to be able to remap the shortcuts in .xml settings (even removing that shortcut completely does nothing), so unless someone has a solution it’s here to stay…

@aksh1yadav / @ovi - any idea on remapping default shortcuts?

Since this is not only PL, if possible it would probably be better to explicitly specify LeftAlt in the shortcuts. Otherwise there will be no © in Romanian workflows either :wink:

1 Like

Just like you, i’ve tried before making some changes in the keyboardmappings.xml file, but weren’t taken into account. I don’t think it’s possible to do it.

I had also tried before but it was not considering changes of keyboardmappings.xml and one more thing i have observed even the keyboardmappings.xml will not exists at its default path then at the time of studio start process a new keyboardmappings.xml will generate with the default configuration.
It is taking from somewhere else. Someone from their side should know more about it :slight_smile:

@ovi - Ask your colleagues :stuck_out_tongue:

Reviving this thread after nearly 3 years because supporting non-US keyboards or adding hotkey configuration is apparently not possible to do in that time frame.

A better workaround for those not wanting to copy-paste symbols from notepad or switching to the US keyboard layout due to productivity impact is to make use of Autohotkey (https://www.autohotkey.com/).

After installing it, right click on the Desktop and create a new AutoHotkey script.

Open it with a text editor and append the following to the bottom of the file:

$^!b::
Send {U+007B}
return

This disables the Ctrl+Alt+B hotkey globaly on Windows and sends the curly brace as input - which was the problem I had with my keyboard layout.

Note that right Alt or AltGr equals Ctrl+Alt.

In the first line ^ is the Ctrl button, ! is the Alt and b the ‘b’ key.

To fix the original poster’s problem use this instead:

$^!c::
Send {U+0107}
return

If you need to overide a different configuration, replace “c” with the key that you need to override and change the UTF-8 output to the UTF-8 code of the character/letter you need: http://www.fileformat.info/info/charset/UTF-8/list.htm

When in doubt there is extensive documentation on how to use Autohotkey available.

Once you are done with the setup, save the file then right click on it and pick “Run Script”.

An icon will appear in the Tray on the right (green icon with H), where you can stop the execution of the script if you need to. The Hotkey should now be disabled in UIPath Studio and elsewhere.

Once you have it working, don’t forget to also post a bug report to UIPath from inside UiPath Studio if you want them to eventually fix this bug:

slika