AI Fabric not enabled


I have upgraded my community version license to enterprise cloud trial in order to learn AI Fabric but getting error as “AI Fabric not enabled for tenant”. AI robot license have been added to the tenant as well but still getting the error.

It would be great if someone could help me to proceed further.

Im getting the same error

Hi @Tinju and @Jersey_Practical_Sho
If you have multiple tenants in your Enterprise Cloud account, make sure you select the tenant where you have allocated the AI Robot license before clicking on AI Fabric.

On the top left corner of the Cloud Portal, click on your Avatar and you should be able to set the current tenant context. See screenshot below

Hi Mathew,

Selected the correct tenant.

Only have the one tenant

Hi all,

We are making some good progress on solving these issues. Here are some workaround in meantime:

  1. try disabling AI Fabric from the tenant and enabling it back.
  2. go to orchestrator service (for instance having AI Fabric enabled) users->roles and check admin role:

    if you see ML Package and ML Skill line but permissions are not checked in you need to create another role having all ML Package, ML Skills and ML Logs granted and assigned it to you. After refresh ML Skill page should be visible on orchestrator and you should be able to connect to AI Fabric.
  3. Create another service and enable AIF on this new service (just remove licenses from other service and allocate them to this new one). Make sure you select right tenant usin tenant switcher on top left before hitting AI Fabric.

Please let us know which one of this work for you (or none if that’s the case). I would expect 3 to always work.

Sorry for the inconvenience!


Hi Jeremy,

Thank you very much for your support.

  1. Disabling and re-enabling AI Fabric from the tenant, didn’t work.
  2. Permissions were already checked in.
  3. This workaround worked perfectly and now I’m able to create AI Project.

Really appreciate your support.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.