After Windows Conversion: "Unable to start execution: An item with the same key has already been added. Key: VisualBasicValue `1_1 "

Hi, everyone. I just converted a bunch of projects from Windows-Legacy to Windows. I tried to run one of them, but it won’t even start executing. I get the following messages:
Unable to start execution

I tried to put some of the advice @Yoichi gave here and here in action, but I cannot see any expressions that use the wrong quotes (ie. instead of ").

Any ideas??



Took a while to dig into this, but I found that after converting a project from the Legacy framework to the Windows framework, it would not compile the Main.xaml any longer.

Eventually, I found that the “VisualBasicValue1_1" key was being used for 2 different transitions. (In addition, "VisualBasicValue1_2” was also being used twice.) The new Windows framework did not like the fact that two transitions were being assigned the same key. (See below.)

All I did to fix it was change one of the “VisualBasicValue1_1" keys to "VisualBasicValue1_6” (which wasn’t being used) and one of the “VisualBasicValue1_2" keys to "VisualBasicValue1_7”. Problem solved.

So weird that the Legacy framework compiled it with duplicate keys but the Windows framework did not.

Hope this helps others!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.