After update to 2019.08 all Gsuite projects stop working, error Type ‘UiPath.GSuite.SimpleObjectContainer’ is not defined

After I upgrade to 2019.08 all my apps get this error when I try to publish them to my attended robots:

Type ‘UiPath.GSuite.SimpleObjectContainer’ is not defined.

BUT if I run the projects from Studio it works without any errors. Only when I want to publish I get this error.

I did not changed anything to my apps, this error appears overnight after the upgrade to 2019.08.

I resolved the error by importing UiPath.GSuite in the project. All good now.


Hi @croko,

I am having this problem and do not know how to import UiPath.GSuite into the project? Could you Explain how to do this?

Aces the ”Imports” tab (located below your flow, next to Variables and Arguments) and the Imports search bar search for UiPath.GSuite and click on it.

If you don’t find it there probably you don’t have the GSuite Package installed FOR that application (the package should be install IN every app you need it) so you should install / reinstall it in that application.


Thank you, it is working now

You are welcome, I’m glad I could help.

Hey. I imported UiPath.GSuite and I also reinstalled the package, yet the project still can’t be published. :frowning:

1 Like

Nevermind. I had to import UiPath.GSuite in every .xaml where I used the GSuite application scope. It works now.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.