Advanced training, InitAllSettings, Read range: The workbook does not exist

excel
configuration
18_1
reframework

#1

I have experienced so many inconsistencies in using UiPath Studio. Here is the latest thing that isn’t working as it did before…
I’m doing the Advanced Training, and yesterday I completed the UiDemo exercise using the REFramework. Today I have started on the Security hash part of the assignment, and using the REFramework, I can’t get the InitAllSettings workflow to run because the Read range in the Get Local Settings sequence is throwing an error that the “Data\Config.xlsx” workbook does not exist.
Well, it certainly exists in my file explorer…

In Studio, looking at the project directory, there is no dropdown arrow for the Data directory…
snapshot2

But if I click the ‘Show all’ button, a dropdown arrow appears, and in the Data directory there is a Config.xlsx file…

Below is a shot of the InitAllSettings workflow with the error in the output at the bottom. Any ideas as to why this is not working? It worked just fine when I went through the UiDemo exercise. I’ve tried:

  • saving a new Config.xlsx file in the Data directory,

  • checking over the permissions on the Config.xlsx file, and other files and irectories withing the REFramework directory,

  • restarting UiPath Studio,

  • starting a new ReFramework project, twice,

  • running the workflow using both Studio 18.1.0 and 17.1.6589


#2

Hi,

I don’t know for sure, but I wonder if it is because InitAllSettings is in a different folder

You could try using "..\Data\Config.xlsx"
EDIT: “..” infront to say back a folder
Or change to Absolute path for now until you get it working correclty.

You can also try using Excel Scope to Read Range incase the activity is not working properly.

Regards.


#3

Thanks, “…\Data\Config.xlsx” worked, but only after I closed 18.1.0 and opened 17.1.6589 to run it, then it ended up working in 18.1.0.
Not sure why my installation of the software is working like this, but It’s frustrating.

Is there perhaps a setting somewhere where the projects root directory is set so that the activities we use will know to start searching for “Data\Config.xlsx” from the root directory?


#4

Hello
I am also facing the same issue. Your methods are not working for me. If I run initAllSetting.xaml it is working fine but when I invoke it from other workflow it shows “Read Range Error”. Please help.


#5

it’s working now. Strange behavior.