Advanced Training Assignment 1 - Get Transaction data is executing in infinite loop for the same transaction

Hi, I am working on assignment 1 in UiPath advanced tranining.
Upto getTransactionData workflow everything is working fine, there are elements in WIList also (which are transactions of type “WI5” and status “Open”)

getTransactionData workflow is executed again and again in infinite loop, not getting where is mistake.

  1. attaching image for getTransactionData Workflow

image

  1. attaching image for arguments in getTransactionData workflow

  2. attaching image for arguments used when getTransactionData workflow is invoked (in main)

Please let me know where is it wrong, i did tried setting transactionNumber to 1, but no help.

Thanks in advance,
Mohini

Please assign the in_TransactionNumber to TransactionNumber

And set the default value of TransactionNumber to 1

did this change, but still same issue exists.
transaction no. is same always and so it is going in loop.

Please assign all IN type arguments.
You must assign the in_wilist for processing the transactions.

i already did that, and even i am priniting in_WIList count (in getTransactionData workflow), and it is 9

i tried priniting both trans no. and wilist count

trans no. is always 1 which is less than 9, and so it is in loop,
but not getting trans no. reference

@mohininemade301094 In Success Transistion from Process state to Get Transaction, In action part increase TransactionNumber variable by 1 using assign activity.

Did this, but still facing same issue.

I think it is not moving further from flow getTransactionData, thats why this might not be working
Thanks,
Mohini

@mohininemade301094 Print the Transaction number in success transaction. check whether value is incremented or not?

1 Like

i tried printing there, but its not printing because some system error is occured in setTransactionStatus for retry: 0 object ref not set…
looking into that , any idea for that ?

Thanks

@mohininemade301094 I dont have idea for it, if u can share workflow i will check it.

Hi, I’ve had the same error as you and after I’ve worked hard at it for the last four days I’ve found a solution to this.
After the Process Transaction, the framework need sum the transaction number, but I think the framework is not doing that. So in the Success of transaction, I made a manual sum of the Transaction number with an assign activitie, like that…Resolu%C3%A7%C3%A3o%20zica

I Hope that works for you too :wink:

1 Like

Oh thanks! i think i have tried this at that time (in january when i did certification), but didnt worked!