Advanced Training(Academy 2) - output argument in Acme1 workflow


#1

in the assigment says:"Create an output argument and assign it the value of the the extracted data
table."
but uipath dont allow assign value how i do that


#2

UiPath (or more specifically Windows Workflow Foundation) doesn’t allow assigning a Default value to an Out or In/Out argument, that doesn’t mean you can’t assign the value at all (that would be counterproductive).

Use Assign activity:
outExtractData = ExtractDataTable


#3

why is counterproductive?


#4

It would be counterproductive to have an Out argument (which sole purpose is to provide a value back to the calling workflow) that you couldn’t assign any value to - it would be literally pointless.

BTW - did you manage to assign the value?


#5

in the framework provide for uipath they use that in the advanced course


#6

Hi ,
May I know where we will be getting this ACME System1 to work on. I didn’t found any web link to this . Please help me. Thanks ,


#7

Hi,

I have the same problem.
I have tried the full table and manual (correlated data) Data Scraping, both with assigning the output directly to the out argument, or to a local variable and then assign this variable to the out argument.
It just refuses to work. There is no functional datatable created for all 4 ways I tried.

Is there anyone that managed to do this part work that maybe can help us?

Kind regards,
Dimitrios


#8

Hey @vineesh . This is link ACME system : https://www.acme-test.com/


#9

I have finally solved this issue with a strange way.
I stopped trying to fix the one produced the error and I just created the whole workflow from scratch, by keeping the default out variable for the data scrapping (ExtractDataTable) and then assigning this variable to the output argument.

Good luck people!


#10

hi I am unable to complete academy 2 1st assignment . is any one have full workflow file that calc client security hash.


#11

witch step?


#13

you can assign it but assign with respected to select method give compile error.

Out DT = Extracted Data.select (“Type=‘Open’”) - will give error saying cant assign from type system.data.datarow[] to type system.data.datatable in assign activity


#14

DataRow[] is not a DataTable nor is it implicitly convertible to one, so error is correct.
You can make a DT from a DataRow[], if you use .CopyToDataTable() at the end.


#15

you mean building data table?


#16

Hello,
I have a question about a error that I can’t understand unfortunatly. I follow the walkthrough file to finish the Uipath 1st assignment but at this particular point I am totally blocked.

Later in the workflow (in the Output Panel) error message will be that the Transaction Number is the one who cannot be with 0 as Value

Could someone please explain where I made the error ?


#17

Hai @jawahar,

for in_TransactionNumber Variable set Default Value as 1 and try.,

Regards,
D.Aravind


#18

Hi @Aravind

Thank you for your reply. I try it and the error message is same. Could my error be in the Config Excel File ?

Thank you for your time and help.

Regards


#20

@jawahar find my xaml file

GetTransactionData.xaml (8.4 KB)

Regards,
D.Aravind


#21

@Aravind

Thank you for your help and time. I will study it and check.

Thanks

Regards


#22

@Aravind,

Thank you very much for your time and help. I corrected the value to 1 as your file. I still have the same message that’s why I cant understand where is my error. In Debbug mode that’s say :

Invoke GetTransactionData workflow Executing
GetTransactionData Executing
GetTransactionData Executing
If more items Faulted
GetTransactionData Faulted
GetTransactionData Faulted
Invoke GetTransactionData workflow Faulted
Log exception message and End process Executing
Error getting transaction data for Transaction Number: 1. Value cannot be null.
Parameter name: source at Source: If more items

Have you an idea from where come my error ?

Thank you for your help

Regards