Advanced Training(Academy 2) - Assignment scoring feedback


I feel that the communication between UiPath assignment evaluators and students is not good enough.
What do I mean?
– I have submitted Assignment 1 which works fine.
– I receive a score of 0/100 with an explanation:
‘Total Items: 14 Completed Items: 0 Correct Items: 0’
– I download the zip assignment from inside the evaluation and it works fine.
– I write a comment and an email to the evaluator requesting details about the nature of the error, so I can fix it and re-submit the assignment
– Still waiting for an answer …

I also see that other students have similar issues, check Unable to proceed further training in Academy2

So, we have a situation where evaluators and students spent lots of time with waiting for feedback and this is not good.

@UiPath: Could you PLEASE post some valuable info regarding the errors that happen during evaluation when you evaluate an assignment? This would save us tons of time!

Kind regards,
Dimitrios Ntakoulas


Just for the record, I have my assignment re/scored.

The only issue was that I had the data reset in the acme website.

Hi Dimitrios,

Thank you for the feedback, it will help us improve your experience on the Academy.

How long did you wait for the assignement to be corrected?

Most frequent errors:

  1. Submit assignment before running the robot, or reset data on ACME and then submit. Have to wait for evaluation before Reset test data.
  2. Parsing strings(attention to details). Ex.: leading or trailing spaces
  3. Not using the same email for both Academy and ACME

Before submitting the assignment, the basic rules would be:

  • Do not reset the test data if the results of your evaluation on one of the assignments are still pending!

  • When registering on, make sure you use the SAME email address you used to create the Academy account!

Hi ovi,

It took me 10 minutes to re-run and re-submit the workflow and around an hour of waiting for the results.

I still believe that giving some error-specific details along with the evaluation result will save some hours for everyone!

Kind regards,


Thank you, I will pass this to the Academy team. Maybe besides the comment received on the Academy, an email with the errors will be also helpful.


Hi Ovi,

For the same workflow I receive different results. No description is given on which WorkItem id does the test fail. Adding those to the result will be much useful

Submitted for review before one hour and its still pending.

Hi Avinash,

Did you get your evaluation?

@Ovi: Got 100/100 thank you

That’s great! Congrats! :tada:


I am facing lots of issues in completing assignment 2 of academy 2. Can you help?..would be grateful

A post was merged into an existing topic: Academy 2 Assignment 1 evaluation error

I think is not as straightforward as one should expect… :wink:

Just try to solve te “business goals” as you can, and that’s all. :wink:

good ur problem is solved. for me inspite of not resetting data its still 0/100
can you please tell me if you executed assignment1 from orchestrator .

how are they able to validate if answers are right

solved for me now. it was the misundersating from PDD to use square brackets to get hash code

@ovi i uploaded my workflow wich is working fine as desired.

but in evaluation i got 1/100 so pls review and let me know about that.
thank u

Hi Bhushan,

Could you attach here a screenshot of your file evaluation? I think the scoring is based on the Total, Completed and Correct items.


1 Like

I’m more interested in the Instructor’s comment on the one with 1/100.

@ovi sorry i got 0/100