Advanced Training(Academy 2) - Assignment 2 / Slow Performance


#1

Hi all.

I’m facing a stranger behaviour with the Assignment 2.
While iterating to download the monthly reports, once the systems allows You to “Save As” an existing monthly report, the flow falls back later on into the “for - each” main block.
At this point, the flow tries to select the next month but it takes a lot of time to discover the UI Element.

I think it’s related with the selectors and the MSIE Explorer Windows ID, that maybe, after one “Save as” window and a second “internal-browser” window (for the downloading information), it seems to loose the control over the principal browser window.

Can some one help me with this, please?

Many thanks in advance


Advanced Training - Assignment 2: Process slows down dramatically
Assignment 2 - selector error
UIPath Advanced Training Assignment 2- Generate Yearly Report
#2

I had the same problem but I did not manage to solve it. I just waited for the workflow to run, submitted passed, done.
I would be very interested in seing an explanation on this.


#3

I too had the same problem but there is no solution to solve this problem because it take minimum 60 secs to move for next controller, If it so means then there is no use of Bot. Manual process will be faster than a Bot


#4

Hi.

Try looking (and playing) with the element properties.
It worked for me.


#5

which property?


#6

Uff… Don’t know.
“Try”. :wink:


#7

atleast any hint for which element I should try the properties?


#8

Hi there,

I’ve investigated this with the Academy team and the slow performance happens after saving the first xlsx. In order to improve the performance, close the pop-up or go to IE options and disable it. Please try like this and let me know if it works.


#9

Try these:

  • “Save As” > Attach as a “Window” window, no as a “Browser”.
  • “On Element Appear” >> “RepeatForEver” == False && “WaitVisible” == True
  • “Click” >> Remember “SimulateClick”

And try. :wink:


Advanced assignment 2 the robot came to slow after save one report
After downlaod a excel file in IE,the flow execute very slow
#10

hi ArturoGarciaMartin,
In the Click Activity change the property Wait for ready to none…it will work fast


#11

Also… Ehehehe…

Thanks, Sanjay


#12

I Would say Mark this as the answer.
And not only for the “Click Activity” I do this for all the activities executed in a loop (For Each Loop for Changing Month in this case). With this my workflow was processing one work item in 2 min.


#13

what’s the format to upload unique id is it Uploaded with ID XXX
or just a id i tried all the ways but no luck doesn’t work


#14

Hi,

It is only the UploadID you need add as a comment and of course the status should be ‘Completed’


#15

@ArturoGarciaMartin could you please explain the “save as” and “on element appear”. I am having the same issue… Very slow performance. For a single client it is taking 35mins to make the status completed.


#16

I also had same issue. This worked for me;;;

“Save As” > Attach as a “Window” window, no as a “Browser”.
“On Element Appear” >> “RepeatForEver” == False && “WaitVisible” == True
Click Activity change the property Wait for ready to none


#17

In my case I encountered the same issues. The solution was to change WaitForReady from Interactive to None


#18

I’m facing the same issue and I have tried all the options suggested above but no luck. Could someone please help me.


#19

Hi @niteshn,

try set WaitForReady = “None” for activities slowly


#20

Hi, Thanks for the reply, yes i have Changed WaitForReady = “None" but no luck. I’m attaching the workflow could you please check and let me know.DownloadMonthlyReports.xaml (27.8 KB)