Advanced Training(Academy 2) - Assignment 1 - Orchestrator exception


#1

Hi everyone,

I am on my way to Academy 2 learning and I am stuck in Assignment 1, here is the situation:

I have installed the trial Platform edition and I am using https://platform.uipath.com/ as my Orchestrator.
I have configured the Robot in my machine and it is connected. The whole setup works fine.

BUT, as I proceed in the ‘Dispatcher - UploadQueue’ sequence, after I have completed all steps, I receive the following exception during execution:

Dispatcher - UploadQueue has thrown an exception

Source: Add queue item

Message: does not exist. Error code: 1002

Exception Type: OrchestratorHttpException

UiPath.Core.Activities.OrchestratorHttpException: does not exist. Error code: 1002
_ at UiPath.Core.Activities.HttpStatusCodeExtension.OrchestratorEnsureStatusCode(HttpResponseMessage response)_
_ at UiPath.Core.Activities.BaseQueueActivity.EndExecute(NativeActivityContext context, IAsyncResult result)_
_ at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)_
_ at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)_
_ at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)_

I have triple-checked that I use the correct ItemInformation and QueueName values, as the walkthrough suggests.

Could someone give me a tip to understand why this exception occurs and maybe how to fix it???

MANY thanks!


#2

And this is what I get while trying to run the job from inside the Orchestrator:

Info : "Executor start process failed, reason System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, OpenSessionInfo sessionInfo, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<b__0>d.MoveNext()"


Usual Orchestrator errors (FAQ) - Troubleshooting
#3

In the Add queue item activity in Studio, make sure the QueueName that you input is not a variable, but simply the Orchestrator queue name, between double quotation marks.


#4

@ahjualune - why? It works just fine with a string variable.


#5

A post was split to a new topic: Academy2 - Assignment 1 - Try Parse - Invalid input value


#6

Me too !. I am also so, there is a way to solve about it ? . I try but i don’t work
Could someone give me a tip to understand why this exception occurs and maybe how to fix it???

Thanks u very much !


#7

Hi ahjualune,

Thanks for your reply.
It did not work either way, but it would not make sense to work with a constant value instead of a variable.

The main question here is not to find a workaround, but understand WHY it happens.

Kind regards,
Dimitrios


#8

Sorry for the confusion. I believe it would work with a string variable easily, provided the variable value is set to the Orchestrator queue name.


#9

Did you resolve this case, i am receiving the same error.


#10

Yes It worked for me.
Just add the queue name as default value in variable.


#11

Did you complete the advance certification


#12

Not Yet :slight_smile: