Advanced Training(Academy 2) Assignment 1 evaluation error


I completed my assignment 1 of academy 2 with no error but when I upload my file and paste my youtube link, I always find fluctuation in results for same file and always giving 0/100.

Can anyone know how to resolve this?


Yes, the key is to NOT reset your test data after you successfully run the process locally. The status of those work items will be “completed”- leave it as is. Then submit your code.

1 Like

@richardli, I did not reset my data after uploading but still im getting only 0
here is the link where first time I run with new data and after that second time when status became completed means without resetting the new data… please check this and help me…

- YouTube from 7.31 mins

1 Like

Em…reset test data as well as make sure you using the same email for ACME system as your UiPath academy email.

@richardli if I reset test data then again WI5 status will be open… and yes I am using same email id…

Correct. don’t reset your test data. I think you might need contact academy team to provide some details on why test failed.

@richardli I tried alot even I raised help ticket still no one is responding and solving my issue. I am struggling with this for past one week… Thanks for your response

1 Like

Hi Sunitha,

So, I’ve watched your video and the problem is when you generate the hash, you have spaces before the name and before the country. That’s why it generates the wrong hash. You have to enter the string with no spaces.

Please try again with no spaces.
Good luck!


Thanks @ovi :slight_smile:


Anyone completed Assignment 1 on Advance Level 3 course? I keep getting below reviews from the reviewer without much details, not sure how to get the details about the incorrect items and reason

Total Items: 15 Completed Items: 15 Correct Items: 0


1 Like

Hi Balram,

What I get from the result is that the workflow you submitted, processes all 15 items, but it does not do it correct.
My best guess is that you may have forgotten to update the work items in the end or you are updating them with incorrect information.


Hi Dimitrios,

Thanks for the update, I understood something is not correct. What is that something? I have followed the instruction as mentioned in PDD and Light walkthru document. Not able to get the point where it went wrong, its dragging me most of the time to know what is wrong here.


Same problem for me also . I followed exact instructions to modify REFramework.Tested all flows of Wi5 and was successful. Also did unit testing… But on upload I get failed 0/100

Hello there,

As Dimitrios mentioned above, maybe the items are not processed correctly.
Check out this post, if for example there are spaces in the string, the generated hash would not be the correct one:

Hi, OVI.

I think I’m facing the same issue with Academy 2 training.
I uploaded the project as a ZIP file, and (twice) the Youtube video.
In all assignments, the score was 0/100.

Can you please, review the scoring?
Video: UiPath Academy 2 - Calculate Client Security Hash - YouTube

Many thanks in advance

Hi Arturo,

After watching your video, it’s the same as Sunitha’s problem with the incorrect generated hash.
The correct text you need to introduce there is ID-NAME-COUNTRY(without )

Hi, OVI.

I saw it!! Thanks.

I’ve re-run the project and it worked fine.
Finally, uploaded a new video and passed the Academy 2 point.

Just “update” the PDF file to avoid these kind of mistakes in the future. :wink:

Thanks for your support!

consulting - COO / Director de OperacionesM: +34 696 817 675
<+34696817675> |
C/ Cristóbal Bordiú, 49 | 28003 Madrid | Spain

1 Like

Yes, thanks for the suggestion, i will talk to my colleagues to put a note or something.

I’m not getting WorkItems even after resetting data.( ACME System 1 - Log In).
Any idea?


Hi skkumar2020,

Are you still having this problem? Is the Work items page empty?