Advanced Assignment 1


#1

Hello,

I’m having trouble extracting structured data for the first assignment in the Advanced training. When I manually enter the “MaxNumberOfResults” it works, but when I enter “0” to get all results, it errors:

System error at initialization: Cannot find the UI element corresponding to this selector: at Source: Extract Structured Data ‘TABLE’

Any suggestions on how to fix this? I’ve tried changing ContinueOnError and the WaitForReady sections with no luck.

Best,

Brad


#2

@bdale04 Ensure that you follow the Walk-through shared in the Assignment. Its quite detailed.

Once you have tried it again. Check my Implementation System1_ExtractWorkItems.xaml (7.6 KB)

Hope this helps. :smiley:

Regards,
Nithin Prabhu


#3

Hi Nithin,

Thank you for sharing. From looking at your workflow, I discovered the only difference was that you have a default value for the extracted data table. When I added the default value as “New System.Data.DataTable”, that fixed my problem.

Do you know why this gave me an error in my workflow, though? Even without this change the workflow operated fine with a manually entered MaxNumberOfResults number. It was only when I wanted to extract all items (“0”) that I got the error.

Also, I do have another minor problem. The first transaction always runs twice. It doesn’t error or anything, so the workflow still functions, but it get’s to the end of the Process workflow then goes back to Get Transaction Data and starts with Transaction 1 again.

Thanks for your help!

Brad