Advanced - Assignment 1 - Work Book Does Not Exist

I went to test the System1 Login flow from the Walkthrough – Calculate Client Security Hash. I received the error below. After some forum searches I was able to clear the debugging error from InitAllSettings. However, the error still populates when running System1 Login. I verified the Asset matches the name used for the Asset in Orchestrator. I tried moving the credentials from the Asset tab to the Settings tab and am still receiving the error. Any insights would be appreciated.

Thank you.

Need more info. What are you trying for an input and what does your data structure look like? The workbook probably doesn’t exist.

It seems like it’s saying that the Config spreadsheet that came with the REFramework in the Data folder doesn’t exist. It does. I already tried remapping the path to see if that was the issue.

@rridlen

Please specify the Excel file path properly.

Hi @rridlen

Try using the debug mode. It will be easier to track the issue. Have a break point somewhere in the init state, then tun it in debug mode. Omce the execution reach the activity you added the break point, do a step by step execution manually… then it will be easy to locate where exactly it is going wrong. You will also be able to see the values that get assigned to variables. Keep an eye on those too

Using debug + breakpoints, the breakdown is definitively at the Invoke InitAllSettings Workflow step. I went back to test the InitAllSettings flow with a write line item at the end of the process and proceeded to test every item from the Config file, and everything is writing to the out_Config dictionary argument as expected.

I checked the path for the InitAllSettings workflow in the invoke step and it matches. I tried to remap it again to be safe. Yet when the workflow is invoked in System1Login, I still get the Workbook Does Not Exist error. I feel like I’m probably overlooking something obvious, but I just can’t put my finger on it.

Still running into the issue so additional screenshots attached. Verified that the value for the in_ConfigFile matches the file’s path on the computer.

I have exact same issue. Th file path Name is:
image
But when I run in debug mode the file path come up as follows and has dropped off the name of the file from the path:

.

Why is this happening ? Thanks :slight_smile:

Hi Colin

Did you find a solution for this. I have same issue running from Orchestrator

Advanced - Assignment 1 - Work Book Does Not Exist

Hi @rridlen

Did you find a solution to this. I have the same issue when running from Orchestrator.

Thanks

I think I ultimately created a new project to get around it. You could try Shift + Right Click - Copy as Path on the Config file and compare it side by side with the path in the argument to double check that it matches.