Advance training 1 Config.xlsx

You showed me what should be sheet SETTINGS ?
Niket_Ghai was wrong? He showed that it is necessary to write the full path to SETTINGS

Why then fill in sheet ASSETS ?

Config must be:
SETTINGS:


ASSETS:

you can store you orchestrator assets in

  1. setting sheet

in Reframework it is by default implemented that if you put your values in setting sheet, while using in framework if you declare variable as credential. Reframework will take care of the bringing the asset from the orchestrator. you just need to pass the assetname to Getappcredentials.xaml

  1. Assets sheet

you need handle all this using an activity( orchestrator asset ).

thanks

This is all true. But I would like to receive a specific answer, which of my screenshots sheets Config.xlsx is correct

both are correct.

if you use settings, in your case 1st sheet, use Getappcredential.xaml (pass UIDemoPath ) as an argument

if you use asset sheet - use orchestrator asset activity to fetch asset from orchestrator

thanks

In task 1 UiDemo it is written:

those in this case I use the argument and SETTINGS will:

there are some unclear steps are there in Level3 assignements, dont just believe everything they have given there. some they have left us to work on and decide

URL you can directly put in setting sheet if you prefer.

but credential should be in orchestrator.

I tried both versions of the Config.xlsx file. The error in InitAllSettings.xaml still remains. I do not know what to do

%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5

What is this variable “LogF_BusinessProcessName” used in activity AddLofFields ?
I did not declare this variable anywhere, either in the fraware, or in Config.xlsxl

can anyone share the dump of activities of level 3. I am not understanding the setting of Config file:(

I did this task! :rofl: Everything worked! :grinning: The problem was in this incomprehensible variable LogF_BusinessProcessName. I assigned it in Config.xlsx
Why about it in any of the instructions were not written? A very poor description has been made of the problem ((

2 Likes

Because it’s ‘Advanced’ Training LOL.

1 Like

What problem your facing…?

I am not understanding how to set up config file. How to give the values for input to getappcredentails.xaml. What ever i have done is not working. Let me know how to assign the values to Asset and how to call them in script?

@lakshmik123

are you using Reframework template…?

in Config.xlsx specify all 3 elements on the SETTINGS. Just do not delete the 2 items that were in the original Config file

I want to add the below setting in config file. But Assigning the values is not working.

It’s a good practice to keep the values that are prone to changes in the configuration file. Open the Data\Config.xlsx workbook and switch to the Settings sheet.
o Add settings for System1 URL and SHA1 Online URL.
o The System1 application requires authentication; we’ll use Orchestrator Assets to store the credentials for System1. Add another setting, System1_Credential, to store the Credential name.
o Add an Asset of the Credential type and write the username and password for System1. Make sure that the Asset name matches the value of the System1_Credential setting.

I tried like in below image. I think i’m wrong somewhere. Can you please help me?

it looks fine. you need to mention assetname for System1_Credentilal asset in settings sheet.

i think your naming convention is not correct: dont put space between variable name you have defined in excel sheet.

while using in workflow you need to use it like this,

config(“System1_URL”).Tostring
config(“SHA1onlineurl”).Tostring

can you paste the error you are getting in workflow…?

thanks

I am getting the following error:
“System error at initialization: Invalid Hyperlink: Malformed URI is embedded as a hyperlink in the document. at Source: Read range settings”

are you connected to orchestrator, is your robot configured ?

Dear, phyogananda
Can You see this my topic? Thanks. I make task №2 in 3 RPA Dev Adv - Calculate Client Security Hash

Hey @Aleksey_M,
First of all, thank you so much for asking these doubts as they have also helped me to gain more clarity on the subject. However, I am also stuck at some point. Please help and reach out at this thread.

Regards,
Harshit Goyal
Problem in getting credentials