Advance training 1 Config.xlsx

academy

#1

Hi.
I do not understand how to fill the file Config.xlsx correctly.
In Assets sheets should I specify only the path to the directory? And Name and Value is “UiDemoPath” ?

And the most difficult. What should I specify in Settings?

  1. Name queues? But what value should be Value?
  2. Name assets from Orchestrator for login to UiDemo ? Name=Value in this case?

Please, help me


#2
  1. For asset sheet use name and value both as UiDemoPath, in the settings sheets set value of UiDemoPath as the path to the directory!
  2. The name column is just like declaring variables i.e these names would be used in your workflow and then from config using their values they will be referenced
    for eg.

    The ‘Value’ column is what you have specified in the orchestrator i.e. the name of your queue in orchestrator.
    The ‘Name’ is what you will use in your workflow!
  3. Same goes for credentials
    Make sure you have the same name in orchestrator and in config file(‘Value’ column)

I hope I was clear in explaining this :slight_smile:
Feel free to clear your doubts.

Regards
Niket Ghai


#3

Thanks , Niket
What does the value REFramework_UiDemo mean on your screen?

In my Orchestrator this data:
QUEUES:


ASSETS

In my Config.xlsx must be ?:
SETTINGS:


ASSETS


#4

you have used directory path in value column, that is not correct. your storing the directory path in orchestrator then use the asset name from the orchestrator in value column.

name

qtransactions qtransactions

Login_UIdemo Login_UIDemo

UIdemoPath UIdemoPath ( in your screenshot i used the value u have given)


#5

You showed me what should be sheet SETTINGS ?
Niket_Ghai was wrong? He showed that it is necessary to write the full path to SETTINGS

Why then fill in sheet ASSETS ?

Config must be:
SETTINGS:


ASSETS:


#6

you can store you orchestrator assets in

  1. setting sheet

in Reframework it is by default implemented that if you put your values in setting sheet, while using in framework if you declare variable as credential. Reframework will take care of the bringing the asset from the orchestrator. you just need to pass the assetname to Getappcredentials.xaml

  1. Assets sheet

you need handle all this using an activity( orchestrator asset ).

thanks


#7

This is all true. But I would like to receive a specific answer, which of my screenshots sheets Config.xlsx is correct


#8

both are correct.

if you use settings, in your case 1st sheet, use Getappcredential.xaml (pass UIDemoPath ) as an argument

if you use asset sheet - use orchestrator asset activity to fetch asset from orchestrator

thanks


#9

In task 1 UiDemo it is written:

those in this case I use the argument and SETTINGS will:


#10

there are some unclear steps are there in Level3 assignements, dont just believe everything they have given there. some they have left us to work on and decide

URL you can directly put in setting sheet if you prefer.

but credential should be in orchestrator.


#11

I tried both versions of the Config.xlsx file. The error in InitAllSettings.xaml still remains. I do not know what to do

%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5

What is this variable “LogF_BusinessProcessName” used in activity AddLofFields ?
I did not declare this variable anywhere, either in the fraware, or in Config.xlsxl


#12

can anyone share the dump of activities of level 3. I am not understanding the setting of Config file:(


#13

I did this task! :rofl: Everything worked! :grinning: The problem was in this incomprehensible variable LogF_BusinessProcessName. I assigned it in Config.xlsx
Why about it in any of the instructions were not written? A very poor description has been made of the problem ((


#14

Because it’s ‘Advanced’ Training LOL.


#15

What problem your facing…?


#16

I am not understanding how to set up config file. How to give the values for input to getappcredentails.xaml. What ever i have done is not working. Let me know how to assign the values to Asset and how to call them in script?


#17

@lakshmik123

are you using Reframework template…?


#18

in Config.xlsx specify all 3 elements on the SETTINGS. Just do not delete the 2 items that were in the original Config file


#19

I want to add the below setting in config file. But Assigning the values is not working.

It’s a good practice to keep the values that are prone to changes in the configuration file. Open the Data\Config.xlsx workbook and switch to the Settings sheet.
o Add settings for System1 URL and SHA1 Online URL.
o The System1 application requires authentication; we’ll use Orchestrator Assets to store the credentials for System1. Add another setting, System1_Credential, to store the Credential name.
o Add an Asset of the Credential type and write the username and password for System1. Make sure that the Asset name matches the value of the System1_Credential setting.

I tried like in below image. I think i’m wrong somewhere. Can you please help me?


#20

it looks fine. you need to mention assetname for System1_Credentilal asset in settings sheet.

i think your naming convention is not correct: dont put space between variable name you have defined in excel sheet.

while using in workflow you need to use it like this,

config(“System1_URL”).Tostring
config(“SHA1onlineurl”).Tostring

can you paste the error you are getting in workflow…?

thanks