Admin rights for Picture in Picture mode

Dear Team,

When working in the Client environment, it is different for the Client IT to activate the PIP mode as the Admin credentials screen appears after the PIP mode is activated. Is it possible to set-up the PIP mode admin credentials through Command Prompt or is there any other alternatives as Client IT cannot provide any admin credentials and this is creating a blocker for deployment.

Thank you



Hi @y.a.ramsurrun,

have you tried enabling below options from settings menu for your automation?

This can be done by using project pane on left side and clicking on settings.


Hi @y.a.ramsurrun,
Ok there may be an official way of getting PIP to work without admin, but sometimes RPA developers do like to live on the edge, so for what its worth I am gonna share a workaround.

To your question. There is a workaround, but I would ask you to confirm with the client the details of your rights and access. If you are a normal user in windows and also have an admin account (help) through the admin account credentials you can get admin rights for a given log in session.

You can use shortcut ctr+r

In the text input use the command window type netplwiz and enter

Your admin / or if you have an admin account already needs to access the GUI once and there you can add your normal user as admin user for the session. This allows your normal user to open PIP in UiPath without a popup for admin password. We use this to allow easier debugging when we are developing on UiPath Studio.

netplwiz command does not have a good reputation in the microsoft forum so thats another thing to be aware of, it works sometimes without registry edits but you can try it anyways.

What does netplwiz command do?
It can give a normal user admin rights for the opened session (until a restart is performed)

What does it allow?
Can convert a normal user session to admin user for the given PC

This workaround may or may not help, but its here for those who want such a solution :slight_smile:

Dear @jeevith ,

Thank you for helping. I really appreciate it.

The client is very strict in terms of accesses. The normal user is only limited to some basic accesses but in case of installing or any upgrades of app , they do not have any access and need to raise a request to the Client IT team. In this scenario, we are completely dependent on the client “say” and approach. We have already added the above into our business case as part of alternatives that will be validated and approved by the Client.

I will keep you posted on the outcome.

Thank you and Best Regards,


Dear @sonaliaggarwal47 ,

Thank you for your reply. I have already tried the steps as per your request, but still the admin rights window will popup after the activation.

If the User already has admin rights on his desktop, then the pop-up will not appear. This is part of the security protocols of the client.



I am on the UIPath forum for this topic as well. We are also in a tightly controlled environment where ordinary users are running bots attended.

I have a bot that has worked flawlessly for months. A few days ago (we believe with a
Windows Update), Picture-in-Picture became disallowed with this message:

“The process you’re trying to run was not tested for Picture in Picture . Running it in PiP may result in unexpected behavior. I you sure you want to start it?”

Our operators click “Yes.” Then they get this:

“Picture in Picture is not enabled on your computer. Do you want us to enable it?”

Again our operators click “Yes.” That’s when UAC demands a local admin password, which they don’t have and must not have.

Both dialogs are generated by UIPath, so we don’t know where the fault really is. (Has some Wndows Update change broken a dependency in UIPath? Or are the users being blocked by some GPO?) To repeat, the bot worked until recently, and UIPath’s friendly prompts mask the cause.

Has this happened to anyone else? Does anyone know what exactly has broken here, and has there been luck in fixing it?

Hello i am also facing the same issue recently, attended bots running fine few days before and now PIP is not working.