Adding a worflow created in Studio to Orchestrator

Hi @anil5, I have tried that and still getting the same issue

Could you go to the Tray Agent and paste here the status message? Is it Robot Unavailable?
If so, please hover over the text “robot unavailable” and type here the error from the pop-up that will be displayed.

@loginerror the error is robot unavailable and the pop up says the machine key is linked to another machine

I think you can go to the MACHINES tab and copy the Machine key of the machine that is called RPA-Student-Dashboard:
image

Use that key to provision your robot.

I believe you are using a Machine key of another machine.

You can also post a screenshot for the Machines tab for more reference :slight_smile: However, I am 100% sure that if you search this Forum for your error message from the pop-up, you will find your solution :slight_smile:

Hi @loginerror, that’s where I copied the machine key from in the first instance :frowning: but I will search the forum more, thank you!

@rparookie97,

Could you provide the screenshot of the orchestrator settings in the robot tray.

@rparookie97, can you please confirm if the machine key is same in orchestrator and robot tray.

Please help with the robot settings.

Can you give a try with the URL, platform.uipath.com in the robot tray

I have changed URL to platform.uipath.com, I only have one machine in my orchestrator and I copy the machine key directly from there and I only have one robot also

@rparookie97,

Why you have 2 different machine names in orchestrator and in Robot Tray (EMMA-PC) and (RPA-Student Dashboard).

Can you also check if the machine key in orchestrator and in robot tray is also same.

2 Likes

It worked! Thank you so much @anil5, I don’t know why I had the machine in orhestrator named differently

Good to know it worked for you.

@anil5, have another issue though I have just went to my UiPath studio to publish a workflow and i’m getting the error,

System.Exception: Publishing the project has failed.

Error: Could not connect to UiPath Robot Service. Make sure the service is started!

I have started the UiPath robot from services.msc and it says it is running?

Hi,

Go to appdata, to the folder where uipath is installed and run the exe file.

“C:\Users\anil\AppData\Local\UiPath\app-19.2.0\UiRobot.exe”

Hi,

That didn’t work, still getting the same error

Hi,

What is the status of your robots in robot tray?

I believe this is related to a known bug. Solution is in this post :slight_smile:

Robot will disconnect randomly if the domain\username field in Orchestrator only contains username.

I have the domain\username in that field in Orchestrator and still getting the error :frowning:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.