Add to dictionary: The Dictionary has not been initialized

I have initialized it with strings while add the Add Dictionary activity. But still while running its showing me error.
Can anybody help.

Hi @Yashaswi_R,

In variable panel, please provide default value as below:
New Dictionary(Of object, object)

NewDict.xaml (4.7 KB)



I changed it to Object,Object but still not working.

Initialize the dictionary within variables panel on default value with:
New Dictionary(Of String, Object)
Ensure that the variable scope is on sufficient level


I have put the a excel application scope then read range->for earch row of read range->Add to dictionary.

Not working.

share details (e.g. screenshots on edited implementation) with us. thanks

This is the outline, I am finding error in add to dictionary.

please show us the variable panel when:

  • reply_particular sequence is activated
  • Body sequence containing the add to dictionary is activated

screenshot of the the property panel from add to dicitionary
share withus the latest error message

Also ensure that the datataype of dictionaty is Dictionary and not IDictionary:

I am adding Dictionary like this

we do see following:

  • MasterDictionary existing on reply_particular scope and sequence scope
    → ensure that MasterDictionary is defined only one time on right scope
  • MasterDictionary was not initialized as mentioned above
    → new Dictionary(Of String, Object)
  • Dictionary Datatype to change as mentioned above
    → Set Datatype to Dictionary (Of String, Object)

Changing the Datatype to Dictionary (Of String, Object) did not work. Same error message occurred.

did you solve this? my dictionary is set to dictionary, and it is coming up in my locals panel as IDictionary and I cant seem to figure out how to fix it.



Even when I switch it to IDictionary it still cannot be initialized. Please help, I’ve tried Dictionary<String, String> Dictionary<String, Object> Dictionary<Object, String> and IDictionary<String, String> IDictionary<String, Object> IDictionary<Object, String>
and the scope is at the top level so there should be a problem accessing this.

I always get “Add to dictionary: The Dictionary has not been initialized”

it should look like this:

otherwise please open a own topic for your case

that did it! Thank you my friend!