Add Queue Item: InHouse_Process4 does not exist. Error code: 1002


Have you created Queue named InHouse_Process4 in Orchestrator or not ?

If not create it first and then try.

Hi Lakshman,

Thanks for the quick response… Infact tried different names but none are working!
Yes, I did create queue named with that:


Why you created that many Queue Names ?

And also show me screenshot of Add Queue Item activity properties and want to see how you passed it.

Added other names since I was confused as the correct name was not taken - was trying different names too… PFB the screenshot (QueueName in the properties is in_Config(“OrchestratorQueueName”).ToString while rest of the fields are empty):


Could you please logout from orchestrator and then relogin again and try once.

Yes, did that several times… stucked with this error since 3 days now :frowning:

1 Like


Do one thing. First delete all QueueName from Excel file. Create one new queueItem in Orchestrator and same put in Excel file and then give it a try once.

Fine @ashoka187

So far your workflow looks good buddy, i think there must be some sort of issue with string or text been fetched from the config…
Kindly follow the below steps that could possibly rectify your issue
–First kindly mention this in your queue name property
–Then make sure that the in_config argument is passed to this workflow and is passed with value
–Try to print the value of this in_Config(“OrchestratorQueueName”).ToString.Trim using a write line activity before this add queue item to check whether the value that we get from write line is correct with queue name…if not we need to check with the config file name attached here or the argument been passed or not
–make sure the orchestrator you want to connect with is correct (may be this can be a last try)

Hope this would you
kindly try this and let know whether this works or not
Cheers buddy @ashoka187

Hi Lakshman,

Did the below activities:

  1. Removed all queuename rows from the excel.
  2. Created a new QueueName with name “NewQueueName” and value as “InHouse_Process4”
  3. Updated the QueueName property of Add Queue Item activity with in_Config(“NewQueueName”).ToString.
  4. Created new Queue on Orchestrator with the name “NewQueueName”

But no luck Yet :frowning:

Hi Buddy,

PFB screenshots of the output and the AddQueueItem section:
Please help me how to check " Then make sure that the in_config argument is passed to this workflow and is passed with value"

Thank you!!

1 Like

PFA the project in zip format for your kind reference… (584.4 KB)

I think we dont need this to be checked as only when the in_config argument is passed correctly we will be getting the output in writeline activity with the string value…so that is fine
Alright…now its all about the orchestrator connected to the machine
–Check whether the machine connected to the orchestrator is correct, make sure you are trying to execute the workflow in a machine and that machine is only connected to the orchestrator, the machine name must be same in both the orchestrator and in your machine
–to find the machine name in your system, go to start->robot
click the uipath robot a small pop up window will be coming, click on the wheel option (setting) and check the name…this name must be there in your orchestrator…
else update the machine name in the robot tab in orchestrator
kindly share the screenshot of the machine name in your system and in orchestrator buddy @ashoka187
This must be the problem i hope
Kindly try this and let know buddy
Cheers @ashoka187

1 Like

Wow, Awesome!!!
There was the problem…My machine got auto-deleted on orchestrator(maybe when uipath got migrated to cloud) which I didn’t notice… I created it back and it started working… Thanks a lot sir!!! PFB the screen on orchestrator, I think thats what got updated:

One last query regarding the other error I am getting… It works some times but most of the times it throws error, can you please help me with some work around??
Error message: Click ‘A /work-items/page-2’: Cannot find the UI element corresponding to this selector:

Selector used: “”

1 Like

Thats fantastic
this error…ok make sure the activity that shows this error is placed inside a attach browser activity and make the dynamic selector attributes been replaced with wild cards…like *
i hope keep it inside the attach browser activity will make the bot identify the element for sure
Kindly try this and let know for any clarification
Cheers @ashoka187

Earlier the activities were placed in attach browser activity itself but the same error was there - hence tried removing. I think the error details that I mentioned in my previous message got mixed with html… PFB the screenshot of error and the selector I used with possible wildcard:

Sorry Venkat, I overlooked your message!!

Fine let the title be like this
title = ‘ACME System 1 - Work Items’
and aaname be like this
aaname = ’ " + in_TransactionItem.ToString + " ’

and pass this selector as a string between double quotes in selector property and dont change the value in selector editor…it wont take into consideration and for more info on how to pass the selector as expression have a view on this

Cheers @ashoka187

were you able to execute now buddy @ashoka187

Hi Buddy,

Unfortunately it isn’t working yet; I have again put back the attach borwser activity and updated the selector as per your suggestion. PFB the screenshot of the output that I am getting:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.