Add data row error lambda expression

I am also facing same issue. Did you find solution for this?

I’ve the same issue!! Did you find any solution?!

I solved this issue by dividing array to two smaller arrays, then concatenating smaller arrays into final big array which will work fine in “Add Data Row” activity.

no! I don’t kown what had happen!

I try to find the rule ,but it happen in the No.17 argument. and another fomat with 107 argument is ok !

When you update to new version,
While you open the project shows the pop up at the top,
Do not Click Convert to windows.

So sad ! I had covered to new vision

Could you please send the xaml.

I also have this problem, and I use the way that keeping the window-legacy that can be worked as usual.


If u use more than 16 different variable in any assign or add data row activity you will face this lambda expression issue.

To fix this, you can add your variables in two different list variables. And add into “add data row” activity based on list index.

List1: 16 variables
List2: balance variables


For this you can try to assign to different array and then concatenate them and pass it to the add data row.
Pass arr3 in add data row.


hi @loginerror Any update on this


Have you tested this, does it work in the same manner?

yes this is working.

1 Like

If you have converted your project from Windows legacy to windows then use this expression(divide your variables in two parts assign one part to arr1 and other to arr2
and then concat and use arr3 variable in add data row it will work.)

Shesherao Patil

Just a small update. The latest System 23.4 should have this issue fixed.

I am Facing the same issue in Studio 23.4, Is there any update on this?

I can see the issue still persist with 23.4 System

Hi @lakshay.verma

What Studio version are you using? I’m afraid that the fix to this issue was actually a Studio side fix and not just the System package. This means that the latest Studio version should have it fixed, and also the latest patch to the older Studio versions.

1 Like

Hi @loginerror,

Business is using 22.10 at the moment.
Because we are using a cloud VM, the patch won’t work, and we can only update the studio in this scenario.
Thanks for the update though.