Activities package error robot account

Hi all,

When I try to run an process at the terminal server, next error appears in the assistent.
So it seems like I have to add more packages versions of the activities to the machine.
Can someone explain me how I van add more versions to the robot account.

Cause:

In those sources, that missing package doesn’t exists.

Solution:

  • Close any Studio windows.
  • Modify the C:\Program Files\UiPath\Studio\NuGet.config as an Administrator user and add the below content:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <packageSources>
  <add key="Local" value="./Packages" />
  <add key="Official" value="https://pkgs.dev.azure.com/uipath/Public.Feeds/_packaging/UiPath-Official/nuget/v3/index.json" />
  <add key="Connect" value="https://gallery.uipath.com/api/v3/index.json" />
  <add key="MyGet" value="https://www.myget.org/F/workflow/api/v3/index.json" />
  <add key="MyGetOrg" value="https://www.myget.org/F/workflow/" />
  <add key="Marketplace" value="https://gallery.uipath.com/api/v2" />
  <add key="UiPath Packages" value="https://packages.uipath.com/activities" />
  <add key="nugetv3.org" value="https://api.nuget.org/v3/index.json" />
  </packageSources>
  <config>
    <add key="signatureValidationMode" value="accept" />
  </config>
</configuration>
  • Make sure that on the impacted robot machine you have access to the external package sources mentioned in C:\Program Files\UiPath\Studio\NuGet.config file
  • Restart the UiPath Robot service if exists in Start → services.msc

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.