Activities not working in Prod which are working in Dev VM


I have developed code in Dev VM and tested completely in Dev and it was error free and working perfectly alright. Recently I pushed the same code from Dev to Prod with all the required configuration replicating the Dev VM.
When i tried to run from Prod, BOT is stopping in some activities due to error and not able to process further. when i tried to re-add the same activity, then it is working( I also checked the activity version and uipath studio ersion in both, both are in same version only).
Can anyone one please tell me the permanant solution to overcome this problem and suggest some solutions to see while migrating from DEV to PROD VM.

please let us know what are the activities you are facing the issue.

Hi @jahar.sil We are facing issue with “Click” and “Type Into” Activities which are working fine DEV VM.


  • Prod env is unattended robot?
  • for click - pls enable simulateclick option
  • for type into - pls enable simulatetype option