Activities get messed up after copy and paste

Hey guys,

I have the problem that the order of the activities get messed up if I try to copy a couple of activites into another sequence. I tried different ways, copy them with ctrl+c or to drag and drop after marking all the activities. I tried the top down marking way and also the bottom up. Sometimes they are copied in the right order but mostly the get messed up.

Is that a bug of the community editon?

In my opinion, it wasn’t like that in the earlier versions.
That is a very frustrating think. Does anyone found a way that works constantly?

Thanks a lot!

Hi @Akimbow,
It’s quite interesting. Could you please share with us some screenshots like the initial state and state after copy was done?

I’ve had this same issue. It only happens in sequences. In my experience, the order is almost always reversed: The first activity (pre-copying and pasting) becomes the last one in the sequence.

It only happens when selecting multiple individual activities and pasting them into a different Sequence scope. Pasting an entire Sequence scope into another one works fine.

Correct. Copy a complete sequence scope into another works but a couple activities without scope get messed up. I have tried several different ways to find out if there is a pattern to know how to do it.
But sometimes it works somtimes it is reversed.
That musst be a bug. I can’t imagine it is a normal approach.

Hi Pablito,

here you go: The activities copied from seq Colour to the right sequence. I put some numbers behind the activity names to see how the order Change after paste into.

1 Like

Thank you very much for this screenshot. We will take closer look on this.

Perfect. Please let me know if you have a solution.

Many thanks.

Meanwhile as a workaround you can put needed activities to separate sequence and copy whole sequence :slight_smile: This should help at least a little :slight_smile:

Thank you.

But I am right, this issue is a bug and should be fixed in the next updates?

Yes, it is a kind of a bug.

What happened with this? I just got the same problem, activities that I copy/paste into a sequence end up upside down.

Could you give us more details?
Studio version, Screenshot etc.

Just happened again so now I can give you some more details:
Studio version is 2024.4.0
As you can see in the screenshot I copied an Assign activity and another acitvity in a try and catch. When I paste the Assign activity ends up after the try and catch.

In this case, the TryCatch is interpreted in whole as an activity, that is why it is happening. Try to select an activity that is placed inside and then paste the Assign activity.

1 Like

OK, thank you, that explains the problem. So the work around is to remove the TryCatch and then copy the selected activities.