Activate activity returned "Timeout reached" error message in UAT server (VM), but works fine on my workstation

Hi All,

Excel was launched by Excel application scope and I am trying to bring Excel application window to the front. I was using Activate activity but it returned “Timeout reached” error message in UAT server (VM), but the activity works fine on my workstation.

Does anyone have an idea on how to solve this? Thank you.

In Vm, whether excel application is installed or not ?

Excel application is installed. Element exists was able to find Excel after Excel application scope launch excel

Give a try, By killing all the excel instances before opeining excel.

it should work…

opened window were all cleaned out before the process start.

And no running apps in Task manager as well. Thanks.

Just a few checks from my side:

  • Within the Excel Application Scope activity ensure that the Visible property is checked
  • Set the output of the Excel application scope to a new variable.
  • Try using ‘set focus’ activity instead of the activate activity
  • Within the ‘Set Focus’ activities properties, set ‘WaitForReady’ to 'complete ’

Hopefully the above will make it a bit more reliable when promoting the code to the test environment, etc.
Let us know how you get on :slight_smile:

Thanks for the suggestion.

unfortunately, this method didn’t work for me.

Instead, I tried click image on the desktop toolbar. Click image is clicking in the DEVE environment, but not clicking in VM.

Below is the selector that I am using.
“wnd app=‘explorer.exe’ cls=‘Shell_TrayWnd’ /”

If you try the following:
(Its not the best way, but its a way to achieve what you’re looking for)

  1. Send Hot Keys in the Citrix Environment to switch between windows (Alt + Shift + Tab). (the key combination only works if the Citrix window is maximized).
  2. After every time you switch window - look for Image Exists Activity to find the window you are looking.
  3. Once the window is found, continue with the next activities in the workflow.

Hope you have some success, but let us know how you get on.

Just thought, if you start a recording (selecting citrix) , select ‘Click Image’& drag around the image of the Excel icon you’re trying to interact with, setting the mouse position as ‘Centre’. Then stop the recording & review. Sometimes i think dragging around the item rather than just simply clicking it to record is a bit more reliable.