Acme test app Arrrggghh! Disappearing dropdowns!

Hi All,

Sorry about this question but it’s driving me mad!

On the Acme test app ACME System 1 - Dashboard (

I can’t select the invoices->search for invoice element

I’ve tried using UiExplorer, hitting F2 so I can bring up the pop up menu but this menu disappears when the F2 time is up.

I have also in UiExplorer in settings activated delayed restore in options but this doesn’t seem to help at all.

What is the method of selecting these type of elements please

I’ve also tried Web recorder which also doesn’t work (after clicking on the invoices button the pop up drop down briefly appears then disappears

Any help would be appreciated.


Hi @charliefik

You can use hoverable action (F6) by indicating the element in a click activity.


Hi @charliefik ,

You can use a work around for this, instead of clicking on it you can directly navigate to that particular URL using the goto URL activity.



1 Like

First Click on Invoices and then use Click OCR text and Set text as “Search for Invoice”

Hi Supriya,

Thanks for the tip but I’m not sure at which point I’m supposed to press F6 (it doesn’t seem to do anything when I’m pressing it)

I’ve tried before and after indicating element and have the same issues as I had before.

I think this may be the solution (it rings a bell) but I’ve no idea how to use the F6 button to do anything useful.

Hi Vishal,

Thanks for the advice but I really want a generic solution to this disappearing element issue. It may not be possible to use a specific URL in every case of a disappearing element, although I appreciate that in this case you can do as you suggest.

Hi Tushar,

Thanks for the advice, I’d really rather not use an OCR solution (except as a last resort) as I don’t find OCR in general to be very reliable. Also I should be able to interact with an element using a selector (if I can only interact with the element)

In modern design there is an option called hoverable element selection while indicating the ui element. You can enable manually or use f6 shortcut to do a hoverable selection. This makes easy in that type of selections. I think you are using classic design so you are not able to find that option.

And in my case I solve the issue by pause the selection and right click the search for invoice button then the menu pop up will not disappear so then I select the search for invoice option.

First you have to use hover activity to indicate the invoice button then use click activity to click the search for invoice option.

1 Like

Hi @charliefik ,

Please find the my below workflow , (32.3 KB)

If any doubt let me know

Mukesh K A

Hi Supriya,

You were absolutely right I was using classic experience (no F6 button). I downloaded the starting code from the UiPath academy (Project Organisation in studio - Practice 3 libraries) and it was in classic mode (they should probably update that). The F6 is available in modern as you said and works great. This is the solution I was looking for

I would however still be interested in knowing how to deal with this situation using the classic toolset as it must have been an issue before modern activities were introduced. If anyone knows

Hi Mukesh,

Thanks for the workflow, which absolutely does work, but I still have no idea how you got the element selector for the click.

Even if you use hover instead of click as you did for the invoices button you are still going to be unable to select the click for search for invoice as it will disappear when you are trying to select the element for the activity.

You seem to be using classic activities so maybe you used the element hierarchy to select the element, I don’t know.

I’m really interested in a general solution to the problem of disappearing elements (such as using the F6 button in modern design) rather than a specific solution where I still have no idea how it was done.

If you can let me know however I would be very interested to understand how this is overcome in classic design.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.