Access to the path..denied

Just after installing StudioX and receiving this error when trying to create a Blank Task. Any help would be appreciated.

Hi @cmckeown

Are you by chance on a machine with strict policies? It looks like StudioX cannot get access to the location as per the error message. Could you try navigating to this location yourself on your harddrive to see if you will be able to see the files?

Are you able to navigate in windows to that location? Does it exist? Also check if one drive/gdrive exists and is synching that location

@cmckeown As per suggestion from @loginerror and @studioX try to create the task in some other folder where you have full access…

If still does not work let us know.

We need more input from you in that case…

Can you try to create a project in a different folder, and try opening that to see whether that works?

Or copy it to another folder and try opening it from there

Hi @loginerror. Yes, my machine does have quite strict security policies, however the installation appears to have been successful (and other colleagues on similar machines have had no issues). When I select Blank Task, the project folder is created within Documents, but StudioX cannot open this project. I do not believe the package ‘C:\Users\cmckeown.nuget\packages\microsoft.extensions.configuration.abstractions\3.1.6’
exists on my machine.

Hi @studioX - I am unable to navigate to this file location - ‘C:\Users\cmckeown.nuget\packages\microsoft.extensions.configuration.abstractions\3.1.6’
Perhaps there is some Microsoft Packages that I need to install first?

Hi @Pravin_Patil1 . I have created the Blank Task in different folders, and have also tried opening the Project from different folders, but with no success. I have uninstalled and re-installed StudioX (from UI Path Academy), but this has not helped my issue.

I cannot find the following packages on my machine. ‘C:\Users\cmckeown.nuget\packages\microsoft.extensions.configuration.abstractions\3.1.6’
exists on my machine.

Could you have a look at this path:
instead of this path:
(note the extra \ character)

Typically the .nuget folder is where the packages are being downloaded when Studio opens a new project.

Hi @loginerror Thanks for spotting my typo, but unfortunately this directory does not exist.
I believe I may be missing the MS Visual Studio Offline Packages.

I have tried installing this package from this link, but I receive this error after installation

Error message:

It could indeed be related to some windows components missing.

Could you double check this list of software requirements:

As per your Windows version.

We had a similar problem and in our case it was related to a security management tool - so if your device is managed I would try talking to the IT if there are certain blocks for the DLLs as the first screenshot is referring to a package version folder which normally contains the DLLs etc.

Simply delete the whole folder in .nuget\packages and run robot again. In my case it worked. The folder was recreated and robot started.

1 Like