Access to path project.json is denied

Hi guys,
I am having a problem when I open a project in UiPath Studio, the activities are not recognized. I try to repair dependencies with the button repair dependencies but it throws an error which is the following.

Access to path ‘C:\NPI\Automation\Work\project.json’ is denied.

This is the path of the robot where is the file (project.json) which have all the dependencies.

The problem is that I can access to that manually, but when I run the studio is not working.
By the way I am working in a VM.

Thanks in advance,

Right click on the project.json and select properties.
Then uncheck “Read only” option and click ok. Now open the project from UiPath Studio.
It should work.

FYI - If you are using source control, its better to do “Check out for edit” and then work on the file/project.

1 Like

I was having the same issue.
Had the project created in another machine. While the same projected is shifted into another one which is used for 24X7, the workflow had some errors regarding packages.
While updating the packages, it was throwing an error like ‘Access to path project.json is denied’.
Checked the parent folder and unchecked the ‘Read Only’ options. Still observed it remained checked even after applying and saving the same.
Lastly I took a back-up of the .joson file and deleted the original one. Opened the ‘Main.xaml’ file again from Studio and it worked.