About Orchestrator publishing error

orchestrator
error
publishing

#1

Hello.
I use Orchestrator CE.
A certain robot doesn’t work well for publishing from today with the error pop-up below:
Error: System.ApplicationException: Publish of workflow project to Orchestrator failed. Error creating UiPath.Core.Model.Package.UiPackage. Duplicate Reference. —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Error creating UiPath.Core.Model.Package.UiPackage. Duplicate Reference.

This happens to the certain robot and others can work well with no problem.
I tried to use another PC to publish and it doesn’t work well.

I want to know why this happens and please tell me how to solve.


#2

I’m running into the same problem today with previously published packages. I’ve been away from Orchestrator for a month on other work. I noticed that all of my processes and packages had disappeared. No problem though, because I thought I would just publish from studio. No luck. I got the same error you did when I published previously published packages. I was, however, able to publish a new package.

Right now I’m thinking it has to do with not having been in Orchestrator for a month and/or UiStudio auto-updating my version and making some kind of change.

Did you find any resolution to your problem?


#3

Came in this morning and thought I would test loading the packages I had gotten the “Duplicate Package” message on yesterday. I was able to load them with no problem today. Maybe the CE Orchestrator going down yesterday helped.

I would try your package again and see if your problem is resolved.


#4

Hi @dhallman

The Orchestrator CE was down yesterday due to an upgrade to 2019.1 :slight_smile: It is probably fixed in the new version.


#5

Yep. Working good now. Thanks.