About Jira Integration error - This activity is either missing or could not be loaded properly

Hello UiPath Community,I am facing this kind of Error with Jira Integration after updating UiPath.

Type ‘Error’ is not assignable to type ‘Error’ of member ‘Body’. Row: 150, Column: 14

Hi @Manali_Vasane

Could you please share a sample workflow that reproduces the issue, as well as the version of your activity package and your Studio?

Jira Software Activity package version -
Studio Version - 2022.4.0


Can anyone guide me how to resolve this issue with Uipath.JiraSoftware.Activities(version
Below are some screenshot for reference.
image (2)

Does this also happen on a newer project? (is it possible for you to install this package on a completely fresh project?).

I have tried installing it on Studio 22.4.1 and it worked just fine.

As a test, and if it will correctly install on a fresh project - does it help if you then move the xaml file to the new project and try to open it from there?

I have tried with new project as well.
it gives me a same error. and this not just happen with me only. but happens with my team members as well.

image (2)

Could you maybe show a screenshot of the project panel with your dependency tree expanded?

image (4)

Any chance you could expand all the branches, especially the JiraSoftware one?

image (5)

All looks good there. I have hard time reproducing the issue.

Could you maybe share your steps to get the Missing or invalid activity error with a freshly made project?
Or share a zip of that freshly made new project here, that would also help a lot.

  1. Add Jira Software Application Scope Activity into sequence.
  2. Then close the project and re-open it.
    you will get this error.

image (6)

EnhancedREFrameWorkTest.zip (1.1 MB)

Great, I managed to reproduce it thanks to your steps. I’ve saved it in our issue tracker for our team to have a look.

1 Like

In the meantime, have you maybe already tried the newer Jira activity package from the Official feed?

yes I tried

sure, Thank You

@loginerror Do you have any updates on this we are getting the same issue

while closing the project and re-open it.

1 Like

Hi @loginerror .

I faced the same issue. The point is that there is pretty old automation, built using jira software activities. Now when we need to adjust it a bit it is not possible.
Is there any update on this issue?


A small update. I talked with our team and it looks like there was an update in Studio 2022.4 to a core dependency that is now in conflict with this older Jira package from the Marketplace. As such, the steps to fix this are to either:

  1. Install the new Jira package in the version 2.3.1 (or higher) and redo the part of the automation that uses Jira

or, in case it is necessary to look at the old code:

  1. Downgrade to the older version of Studio to open the project (i.e. your previous version that it worked on).
  2. Install the newer Jira activity package alongside the old one
  3. Redo the code with new Jira activities
  4. Delete old activities from the workflow, delete the old activity package and upgrade Studio to 2022.4.

Hi @loginerror : I have recently upgraded from Studio 2021.4.4 to 2022.4.3 and observed same error for already deployed process because of comglict with old version of UiPath.JiraSoftware.Activities =

Now same build is showing Dependencies (Windows - Legacy) in Project with this error. When i opened same build in Studio 2021.4.3 → It shows only Dependencies in Studio but project.json is same for both.

Will it impact —》 if i run same build for 2022.4.3 robot service?

How to mitigate this? → As suggested, new activities usage are quite different than previous version (for e.g. update fields in Jira tickets). It is not good practice to build deployed process again with new activities just because of version conflict.

1 Like