About disabling Orchestrator local login

I am using AD authentication to login Orchestrator, but I can also local login directly from the login screen.
How do I disable local login?
Orchestrator Version:2019.10.19

Hi @miito_0320

Refer the link

Regards
Gokul

Thank you for your help @Gokul001
The method you suggested seems to be applicable only to Windows AD.
Is it impossible for Azure AD?

Hi @miito_0320 ,

Could you pls refer below thread it is having steps to disable the local login for Azure AD I think. I hope it might helpful to resolve your issue. Thanks.

Thank you for your information @kirankumar.mahanthi1
In my environment, appsettings.json did not exist under /site/wwwroot/,
but I added the following to appSettings in web.config, and it worked well :slight_smile:

<add key=“Auth.RestrictBasicAuthentication” value=“true” />
<add key=“Auth.EnableBasicAuthenticationForHostTenant” value=“false” />

1 Like